# 업그레이드 후 로그인 불가

**URL:** https://meta.discourse.org/t/cannot-login-after-upgrade/136870
**Category:** Support
**Created:** [12월 23, 2019, 8:13오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870 "2019-12-23T08:13:50Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![nephilim75](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/nephilim75/32/158254_2.png) [@nephilim75](https://meta.discourse.org/u/nephilim75)
#### Post date: [12월 23, 2019, 8:13오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870/1 "2019-12-23T08:13:50Z")

</div>

안녕하세요

업그레이드 이후 관리자 계정이나 다른 어떤 계정으로든 로그인할 수 없습니다. `./launcher rebuild app` 명령을 사용하여 재구성을 시도해 보았지만 효과가 없었습니다. 여전히 로그인이 불가능한 상태입니다.

어떤 아이디어나 해결책이 있을까요? 추가로 도움을 드리기 위해 어떤 정보가 필요하신가요?

감사합니다  
//neph

---

<div class="post-metadata">

### Author: ![sau226](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sau226/32/302324_2.png) [@sau226](https://meta.discourse.org/u/sau226)
#### Post date: [12월 23, 2019, 8:25오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870/2 "2019-12-23T08:25:31Z")

</div>

문제가 무엇인지 더 구체적으로 설명하는 것부터 시작해 보시는 것이 좋습니다. "관리자든 다른 사용자든 로그인할 수 없다"는 내용은 매우 모호합니다. 오류 로그 항목이나 오류 화면 캡처를 제공해 주시면 도움이 될 것입니다. 로그를 가져오는 방법에 대한 지침은 아래 링크를 참고하세요. 아마도 rails 로그를 확인하게 될 것입니다.

> [@Where does Discourse store and show logs?](https://meta.discourse.org/t/where-are-all-the-discourse-logs/58022):
>
> When troubleshooting issues or errors with Discourse it is important you look at your logs. Here’s a listing of where they are and what’s in there. Your site domain Administration logs shown in the UI The Discourse admin panel contains several forms of logging: Emails that are sent, skipped, bounced, received and rejected are logged at https://=DOMAIN=/admin/email-logs and the neighboring tabs. Staff actions are logged at https://=DOMAIN=/admin/logs/staff\_action\_logs Email addresses an…

관련 로그 데이터와/또는 화면 캡처를 제공해 주시면, 저희(커뮤니티)가 더 효과적으로 도움을 드릴 수 있습니다.

---

<div class="post-metadata">

### Author: ![nephilim75](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/nephilim75/32/158254_2.png) [@nephilim75](https://meta.discourse.org/u/nephilim75)
#### Post date: [12월 23, 2019, 9:08오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870/3 "2019-12-23T09:08:49Z")

</div>

로그인이 끝없이 계속되고 있습니다. 오류 메시지도 없습니다. 어쨌든, 닥터(의사)가 힌트를 주었습니다. 앱이 시작되지 않는 것 같습니다.

```plaintext
root@debian-4gb-nbg1-1:/var/discourse# ./launcher start app

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (34a973985c824743faf32d44ba96b910b54adb3413a9f2de411cd6fe2b122d8d): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use
Error: failed to start containers: app
root@debian-4gb-nbg1-1:/var/discourse#

```

이 문제가 무엇을 가리키는지 혹시 아는 분 있나요?

---

<div class="post-metadata">

### Author: ![nephilim75](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/nephilim75/32/158254_2.png) [@nephilim75](https://meta.discourse.org/u/nephilim75)
#### Post date: [12월 23, 2019, 9:29오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870/4 "2019-12-23T09:29:57Z")

</div>

글쎄, 결국 작동하게 만들었습니다. 포트 설정을 확인하고 nginx 서비스를 중지한 후 앱을 시작했습니다. 이제 컨테이너가 정상적으로 시작되었고, 로그인도 성공적으로 완료되었습니다.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [12월 23, 2019, 10:18오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870/5 "2019-12-23T10:18:34Z")

</div>

nginx를 제거했는지 확인하세요.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [1월 22, 2020, 10:18오전 UTC](https://meta.discourse.org/t/cannot-login-after-upgrade/136870/6 "2020-01-22T10:18:37Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
