Cannot reach images folder via ssh terminal


(Ankhamax) #1

I cannot reach the following folder via ssh

/var/www/discourse/public/images

It keeps returning the “/var/www: No such file or directory”. How to solve it?

I am trying to upload the logo of my site.

Thanks


(Mittineague) #2

You don’t do it that way.

As explained in
READ ME FIRST: Admin Quick Start Guide

go to
Assets for the site design

and post them it that topic.
Then get the URL and use that.


(Ankhamax) #3

Thank you, @Mittineague


(Sander Datema) #4

And that part is because you need to be in the Docker container. Use e.g. launcher enter app to enter the container (if it’s using the file app.yml in the containers folder).


(Ankhamax) #5

Where do I execute this command in order to get in the Docker container?


(Sander Datema) #6

From the same place where you installed Discourse using launcher: /var/discourse


(Ankhamax) #7

Sorry, when I tried to run the launcher enter app the command from /var/discourse it displayes “launcher: command not found”.


(Ankhamax) #8

@Sander78 Never mind, it worked. Thank you.


(Sander Datema) #9

Did you run launcher or ./launcher? Should be the latter.

Edit: ah, you solved it already.


(Ankhamax) #10

@Sander78 I am trying to upload file from my computer to the /var/discourse/ on terminal. Is there special command that I need to execute? I am trying but no luck so far.

Thanks


(Sander Datema) #11

I’m not sure what you’re trying to do and it seems it’s out of the scope of Discourse. This is about learning how to transfer files over SSH to your VPS box (I suppose).

Can you give a little more context? What files and for what reason are you trying to upload to /var/discourse?


(Felix Freiberger) #12

Note that this is the only supported way to upload images. You can use launcher enter app to get inside the container, but you should not place any files there as they will be deleted when the container is rebuilt.

The enter command is only there for debugging or to run commands inside the console, e.g. to manually change a setting for all users.