Cannot upgrade from admin interface


#1

Hi All,

For quite some time (around the last year) I have not been able to upgrade Discourse from the admin interface. Whenever an upgrade is available the “Upgrade to the Latest Version” button is greyed out as docker_manager says it is “Currently Upgrading” - but it never finishes (starts?) and when I click the button to check the status it just shows a blank black window.

I am able to upgrade via the CLI doing a manual pull and rebuild, and when I do this and go back into the upgrade section of the user interface it shows everything as up-to-date. However, I thought I should finally fix this problem so that I can upgrade from the admin interface and don’t have to do a manual upgrade each time.

Any suggestions would be welcome, thanks!


(cpradio) #2

See this, as it sounds like you are running into this issue too


(Jeff Atwood) #3

We should change how this page works so it doesn’t spam the parent site with version check http requests when there are a zillion plugins @eviltrout.


#4

Thanks for the replies everyone, but I have been getting this error for a long time and I also have no other plugins apart from Discourse Solved.


(Jeff Atwood) #5

Hmm that’s really odd, so you are doing

cd /var/discourse
git pull
./launcher rebuild app

at the SSH command line? That should leave you in a known state.

Also have you rebooted the machine? If it thinks it is upgrading that implies redis is carrying state.


#6

Yep, that’s right. Then every time a new update comes out the problem returns - need to SSH to upgrade, as the admin interface is stuck on the docker_manager upgrade.

I haven’t rebooted in a while, so I will do a CLI update and then reboot and then wait to see whether it happens again on the next update that’s released.


(cpradio) #8

Can you Press F12 and go to the network tab and then refresh the /admin/upgrade page? As I’m curious what error you are getting.


#9

Sorry about the delay - needed to wait for another update to come out.

So, this morning I was alerted that 1.5.0beta14 is available and I have the same issue as always: docker_manager is stuck upgrading (and it was not initiated by me - it was like that when I went to the /admin/upgrade page):

When I click the “Currently Upgrading…” button it’s just a blank black window:

@cpradio - thanks for your suggestion. However, where should I press F12? I have tried in the /admin/upgrade page and also on the /admin/upgrade#/upgrade/docker_manager page but nothing happens.

@codinghorror - I have tried rebooting the machine (in fact, I did this after the last upgrade which I needed to do on the CLI due to this issue), but that’s not fixed the issue since it’s back again now.


(Jeff Atwood) #10

I recommend upgrading from the command line, it’s possible Docker itself is out of date, or the container definition. SSH into the server and

cd /var/discourse
git pull
./launcher rebuild app

If you get an error about Docker version, you need to update Docker itself. While you are in there via SSH can you also report docker version and docker info and free -m and df -m?

Sounds like there’s just some kind of fundamental problem with your install, we’ve never seen this before.


#11

Thanks for your reply. Regarding the CLI upgrade, that’s what I have been doing for the past year while this problem has been occurring - unfortunately it has never resolved itself.

Here’s the results of the commands:

# docker version
Client:
 Version:      1.9.1
 API version:  1.21
 Go version:   go1.4.3
 Git commit:   a34a1d5
 Built:        Fri Nov 20 17:56:04 UTC 2015
 OS/Arch:      linux/amd64

Server:
 Version:      1.9.1
 API version:  1.21
 Go version:   go1.4.3
 Git commit:   a34a1d5
 Built:        Fri Nov 20 17:56:04 UTC 2015
 OS/Arch:      linux/amd64


# docker info
Containers: 1
Images: 52
Server Version: 1.9.1
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 54
 Dirperm1 Supported: false
Execution Driver: native-0.2
Logging Driver: json-file
Kernel Version: 3.13.0-43-generic
Operating System: Ubuntu 14.04.3 LTS
CPUs: 2
Total Memory: 1.955 GiB
Name: forum.cgscomputing.com
ID: 3TMD:B6OX:EFIU:W4Y6:BRMQ:CSXZ:MAMA:LGXG:SLPW:HNRO:XNDW:XKTB
WARNING: No swap limit support


# free -m
             total       used       free     shared    buffers     cached
Mem:          2001       1901        100         60        217        207
-/+ buffers/cache:       1476        525
Swap:            0          0          0


# df -m
Filesystem                1M-blocks  Used Available Use% Mounted on
udev                            991     1       991   1% /dev
tmpfs                           201     1       200   1% /run
/dev/disk/by-label/DOROOT     40188 23857     14267  63% /
none                              1     0         1   0% /sys/fs/cgroup
none                              5     0         5   0% /run/lock
none                           1001     2      1000   1% /run/shm
none                            100     0       100   0% /run/user
none                          40188 23857     14267  63% /var/lib/docker/aufs/mnt/ac867ead137b5905617f0e4b586ff60b93e082166619d95251630eb6bd5b7523
shm                              64     0        64   0% /var/lib/docker/containers/ac867ead137b5905617f0e4b586ff60b93e082166619d95251630eb6bd5b7523/shm

(Jeff Atwood) #12

Those stats look OK.

Do you have any third party plugins installed? If so remove them and try again.


#13

Only discourse-solved, no other plugins.

(and the problem was happening before I installed that plugin as well).


(Jeff Atwood) #14

Sorry, I really have no idea. We haven’t seen this on other installs. Did you deviate from anything (and I mean literally anything) in our default cloud setup doc?


#15

No worries. Not that I am aware of - it worked fine after the original install, the problem only started happening about six months afterwards. Bit of a mystery…


(Maurizio Marini) #16

Hello, I have the same issue, docker
Upgrade docker_manager
Start upgrade button clicked
Black empty window
nothing happen

My question is, docker should be updated using cycle:

apt-get update
apt-get upgrade

or something else? this is Debian Jessie box

docker version
Client:
 Version:      17.05.0-ce
 API version:  1.29
 Go version:   go1.7.5
 Git commit:   89658be
 Built:        Thu May  4 22:04:27 2017
 OS/Arch:      linux/amd64

Server:
 Version:      17.05.0-ce
 API version:  1.29 (minimum version 1.12)
 Go version:   go1.7.5
 Git commit:   89658be
 Built:        Thu May  4 22:04:27 2017
 OS/Arch:      linux/amd64
 Experimental: false

 # docker info
Containers: 1
 Running: 1
 Paused: 0
 Stopped: 0
Images: 5
Server Version: 17.05.0-ce
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 18
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 9048e5e50717ea4497b757314bad98ea3763c145
runc version: 9c2d8d184e5da67c95d601382adf14862e4f2228
init version: 949e6fa
Kernel Version: 3.16.0-4-amd64
Operating System: Debian GNU/Linux 8 (jessie)
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 1.963GiB
Name: viepossibili
ID: ZS3Z:37LN:QXXO:VT5W:FPQP:LLVS:R5ZB:HORB:B2PB:G2M2:WKLH:CM3Z
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false

WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support

(Allen - Watchman Monitoring) #17

If you see a button stuck at “updating” it happens from time to time… see here

however, it’s not clear that your error is related to this topic. Maybe start a new one?