# Can't delete this category because it has 1 topic

**URL:** https://meta.discourse.org/t/cant-delete-this-category-because-it-has-1-topic/174648
**Category:** Support
**Created:** [December 30, 2020, 9:50pm UTC](https://meta.discourse.org/t/cant-delete-this-category-because-it-has-1-topic/174648 "2020-12-30T21:50:02Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![sunjam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sunjam/32/175682_2.png) [@sunjam](https://meta.discourse.org/u/sunjam)
#### Post date: [December 31, 2020, 6:11pm UTC](https://meta.discourse.org/t/cant-delete-this-category-because-it-has-1-topic/174648/6 "2020-12-31T18:11:44Z")

</div>

Okay, I’m seeing 3 errors in the log. They are:

1st error

> **Summary**
>
> Message
> 
> ActiveRecord::StatementInvalid (PG::UndefinedTable: ERROR: relation “categories” does not exist  
> LINE 1: SELECT categories.\*, t.slug topic\_slug FROM “categories” LEF…  
> ^  
> )  
> (eval):105:in `exec_params' app/models/site.rb:40:in `categories’  
> app/models/site.rb:12:in `initialize' app/models/site.rb:113:in `new’  
> app/models/site.rb:113:in `json_for' app/controllers/application_controller.rb:552:in `preload\_anonymous\_data’  
> app/controllers/application\_controller.rb:378:in `preload_json' app/controllers/application_controller.rb:358:in `block in with\_resolved\_locale’  
> app/controllers/application\_controller.rb:358:in `with_resolved_locale' lib/middleware/omniauth_bypass_middleware.rb:68:in `call’  
> lib/content\_security\_policy/middleware.rb:12:in `call' lib/middleware/anonymous_cache.rb:352:in `call’  
> config/initializers/100-quiet\_logger.rb:23:in `call' config/initializers/100-silence_logger.rb:31:in `call’  
> lib/middleware/enforce\_hostname.rb:22:in `call' lib/middleware/request_tracker.rb:176:in `call’
> 
> Backtrace
> 
> rack-mini-profiler (2.2.0) lib/patches/db/pg.rb:69:in `exec_params' rack-mini-profiler (2.2.0) lib/patches/db/pg.rb:69:in `exec\_params’  
> (eval):105:in `exec_params' activerecord (6.0.3.3) lib/active_record/connection_adapters/postgresql_adapter.rb:675:in `block (2 levels) in exec\_no\_cache’  
> activesupport (6.0.3.3) lib/active\_support/dependencies/interlock.rb:48:in `block in permit_concurrent_loads' activesupport (6.0.3.3) lib/active_support/concurrency/share_lock.rb:187:in `yield\_shares’  
> activesupport (6.0.3.3) lib/active\_support/dependencies/interlock.rb:47:in `permit_concurrent_loads' activerecord (6.0.3.3) lib/active_record/connection_adapters/postgresql_adapter.rb:674:in `block in exec\_no\_cache’  
> activerecord (6.0.3.3) lib/active\_record/connection\_adapters/abstract\_adapter.rb:722:in `block (2 levels) in log' activesupport (6.0.3.3) lib/active_support/concurrency/load_interlock_aware_monitor.rb:26:in `block (2 levels) in synchronize’
> 
> Env
> 
> HTTP HOSTS: discuss.noisebridge.info

2nd error

> **Summary**
>
> Message (3 copies reported)
> 
> ActiveRecord::StatementInvalid (PG::UndefinedTable: ERROR: relation “categories” does not exist  
> LINE 1: SELECT categories.\*, t.slug topic\_slug FROM “categories” LEF…  
> ^  
> )  
> (eval):105:in `exec_params' app/models/site.rb:40:in `categories’  
> app/models/site.rb:12:in `initialize' app/models/site.rb:113:in `new’  
> app/models/site.rb:113:in `json_for' app/controllers/application_controller.rb:552:in `preload\_anonymous\_data’  
> app/controllers/application\_controller.rb:378:in `preload_json' app/controllers/application_controller.rb:358:in `block in with\_resolved\_locale’  
> app/controllers/application\_controller.rb:358:in `with_resolved_locale' lib/middleware/omniauth_bypass_middleware.rb:68:in `call’  
> lib/content\_security\_policy/middleware.rb:12:in `call' lib/middleware/anonymous_cache.rb:352:in `call’  
> config/initializers/100-quiet\_logger.rb:23:in `call' config/initializers/100-silence_logger.rb:31:in `call’  
> lib/middleware/enforce\_hostname.rb:22:in `call' lib/middleware/request_tracker.rb:176:in `call’
> 
> Backtrace
> 
> rack-mini-profiler (2.2.0) lib/patches/db/pg.rb:69:in `exec_params' rack-mini-profiler (2.2.0) lib/patches/db/pg.rb:69:in `exec\_params’  
> (eval):105:in `exec_params' activerecord (6.0.3.3) lib/active_record/connection_adapters/postgresql_adapter.rb:675:in `block (2 levels) in exec\_no\_cache’  
> activesupport (6.0.3.3) lib/active\_support/dependencies/interlock.rb:48:in `block in permit_concurrent_loads' activesupport (6.0.3.3) lib/active_support/concurrency/share_lock.rb:187:in `yield\_shares’  
> activesupport (6.0.3.3) lib/active\_support/dependencies/interlock.rb:47:in `permit_concurrent_loads' activerecord (6.0.3.3) lib/active_record/connection_adapters/postgresql_adapter.rb:674:in `block in exec\_no\_cache’  
> activerecord (6.0.3.3) lib/active\_record/connection\_adapters/abstract\_adapter.rb:722:in `block (2 levels) in log' activesupport (6.0.3.3) lib/active_support/concurrency/load_interlock_aware_monitor.rb:26:in `block (2 levels) in synchronize’
> 
> Env
> 
> HTTP HOSTS: discuss.noisebridge.info

3rd error

> **Summary**
>
> Message
> 
> Job exception: PG::UndefinedTable: ERROR: relation “application\_requests” does not exist  
> LINE 1: SELECT “application\_requests”.“id” FROM "application\_request…  
> ^
> 
> Backtrace
> 
> /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/rack-mini-profiler-2.2.0/lib/patches/db/pg.rb:69:in `exec_params' /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/rack-mini-profiler-2.2.0/lib/patches/db/pg.rb:69:in `exec\_params’  
> (eval)💯in `exec_params' /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.3.3/lib/active_record/connection_adapters/postgresql_adapter.rb:675:in `block (2 levels) in exec\_no\_cache’  
> /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.3.3/lib/active\_support/dependencies/interlock.rb:48:in `block in permit_concurrent_loads' /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.3.3/lib/active_support/concurrency/share_lock.rb:187:in `yield\_shares’  
> /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.3.3/lib/active\_support/dependencies/interlock.rb:47:in `permit_concurrent_loads' /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.3.3/lib/active_record/connection_adapters/postgresql_adapter.rb:674:in `block in exec\_no\_cache’  
> /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.3.3/lib/active\_record/connection\_adapters/abstract\_adapter.rb:722:in `block (2 levels) in log' /var/www/discourse/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.3.3/lib/active_support/concurrency/load_interlock_aware_monitor.rb:26:in `block (2 levels) in synchronize’

---

_[View the full topic](https://meta.discourse.org/t/cant-delete-this-category-because-it-has-1-topic/174648)._
