Can't get email to send?


#1

I’m trying to get my Discourse server working with the digital ocean droplet, and I always get to the point where I can sign up, but the email never sends. I’m going into my cpanel email area, and for the SMTP server, there’s a mail.mywebsite.com for non ssl and then the ssl enabled server, and I’ve tried them both. I also tried to do the suggestions, but the SSH simply can’t find any of the files. I’m sure I’m just doing something wrong on there since it’s obviously set up. Just really unsure why the email isn’t working.


(Jeff Atwood) #4

You will need to follow the email troubleshooting #howto topic closely. There’s nothing unique about this topic. Answer each step of that troubleshooting document in explicit detail.


(Jeff Atwood) #5

I also strongly suggest purchasing an install from https://www.literatecomputing.com because then the email will be set up for you correctly and automatically.


#6

That’s the thing. I went here: Troubleshooting email on a new Discourse install

I tried typing in this: containers/app.yml in putty, and it just says the file doesn’t exist.

I’ve honestly went through everything from your how to back in 2014 I believe to the digital ocean one. I’m not sure what I’m missing.


(Jeff Atwood) #7

Like I said, easiest thing to do is purchase the $99 install from https://www.literatecomputing.com/ if you don’t want to spend the time troubleshooting. Depends on the value of your time, etc :wink:


(Christoph) #8

Note that the path does not start with a /. The full path of the file is /var/discourse/containers/app.yml