Can't load suggested topics using "Enter"

keyboard

(TechnoBear) #1

Since I logged in here a few minutes ago, I’ve been unable to access any “suggested topic” by using j/k to navigate to it and pressing “Enter” (my usual method of navigation). Every time, I get a message “Sorry, we are unable to load that topic, possibly due to a connection problem” or something similar and it reloads the topic I was viewing.

The links work if visited by mouse - and seem to work by keyboard after being visited by mouse, although I’m not entirely sure about that.

The problem does not occur on our own instance; only on Meta.


(cpradio) #2

I don’t get the connection screen, but I do get it to only refresh the current page, if I do the following:

  1. Use j to get to the first Suggested Topic
  2. Press k to go back up to the last post
  3. Press j to go back to the first suggested topic
  4. Press Enter

I can get the suggested topic to load property when I use the following steps

  1. Use j to get to the first suggested topic
  2. Press Enter

So why does navigating off it, and back on it, cause it to behave improperly? Looking at the markup, it isn’t changing much.


(cpradio) #3

Also, seems using o works 100% of the time, Enter doesn’t.


(TechnoBear) #4

That’s not what I was doing. I was using j to navigate to the first suggested topic, and Enter to try and open it. After I’d been returned to the original topic, I tried again several times, with the same results. I then tried navigating to the second suggested topic instead - but with the same result. Oddly, it didn’t happen when I posted this topic, but did again with the next topic I entered. I’ll see what happens after I post this.

Edit: Exact same problem; j to reach first suggested topic, Enter and then the error message, before being returnedhere.

(Firefox 32.0.3 on Ubuntu Gnome.)


(cpradio) #5

If you use ‘o’ does it work?


(TechnoBear) #6

OK, tried that and it seems to, yes. (But I much prefer Enter…)


(cpradio) #7

Oh, I know. I do to, but I find it interesting that they work differently all of a sudden. I just looked at the keyboard_shortcut code and it doesn’t seem to have changed (for these keys).


(TechnoBear) #8

I agree it’s odd that one should work and not the other, and I’ve only had problems on Meta, and only today.

(Firefox spellcheck also works on SitePoint and not on Meta…)


(Robin Ward) #9

I checked in a fix for this on Monday:

https://github.com/discourse/discourse/commit/a2c97b9e6bde310b523a1c06f23003ec105af957


(Régis Hanol) #10