# Can't rebuild app

**URL:** https://meta.discourse.org/t/cant-rebuild-app/53648
**Category:** Self-hosting
**Created:** [2016年十二月1日 22:52 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648 "2016-12-01T22:52:22Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![companyhen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/companyhen/32/121250_2.png) [@companyhen](https://meta.discourse.org/u/companyhen)
#### Post date: [2016年十二月1日 22:52 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/1 "2016-12-01T22:52:22Z")

</div>

root@forum:/var/discourse# ./launcher rebuild app  
Ensuring launcher is up to date  
Fetching origin  
Launcher is up-to-date  
Stopping old container

- /usr/bin/docker stop -t 10 app

I’m not using spaces instead of tabs.

I went to cd var/discourse/ and edited my app.yml

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2016年十二月1日 23:02 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/2 "2016-12-01T23:02:00Z")

</div>

You need to include more information about what is wrong. Are there any error messages when you run rebuild?

---

<div class="post-metadata">

### Author: ![purldator](https://avatars.discourse-cdn.com/v4/letter/p/bcef8e/32.png) [@purldator](https://meta.discourse.org/u/purldator)
#### Post date: [2016年十二月1日 23:03 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/3 "2016-12-01T23:03:00Z")

</div>

Also, [make sure your app.yml has no white space errors.](http://www.yamllint.com/)

---

<div class="post-metadata">

### Author: ![companyhen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/companyhen/32/121250_2.png) [@companyhen](https://meta.discourse.org/u/companyhen)
#### Post date: [2016年十二月1日 23:17 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/4 "2016-12-01T23:17:38Z")

</div>

I got disk space error and ran .launcher cleanup but didn’t do anything. Don’t see any other errors or anything in logs

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2016年十二月1日 23:19 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/5 "2016-12-01T23:19:30Z")

</div>

Do you have any disk space? What does

```
df -h

```

say?

---

<div class="post-metadata">

### Author: ![companyhen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/companyhen/32/121250_2.png) [@companyhen](https://meta.discourse.org/u/companyhen)
#### Post date: [2016年十二月1日 23:22 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/6 "2016-12-01T23:22:31Z")

</div>

```
root@forum:/var/discourse# df -h
Filesystem Size Used Avail Use% Mounted on
udev 991M 4.0K 991M 1% /dev
tmpfs 201M 500K 200M 1% /run
/dev/disk/by-label/DOROOT 40G 17G 21G 44% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 1001M 1.3M 1000M 1% /run/shm
none 100M 0 100M 0% /run/user
none 40G 17G 21G 44% /var/lib/docker/aufs/mnt/fb252918102669de460d6a083c37b087e44d7d437cdf350ca7799b24350685ba
shm 64M 0 64M 0% /var/lib/docker/containers/71c4e8fce05b3079cc7c6fc78b973e10405a26baefe18b4bb60b1ee80cb98e25/shm
none 40G 17G 21G 44% /var/lib/docker/aufs/mnt/8bc2f192258dbaf244a3a4577d076665b99d8053964e271f1e3b527ef84f9cfc
shm 64M 4.0K 64M 1% /var/lib/docker/containers/6b89515ace621e4398653f1318218b40eab017dce620dd08d12cbf34dbacbd24/shm

```

---

<div class="post-metadata">

### Author: ![companyhen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/companyhen/32/121250_2.png) [@companyhen](https://meta.discourse.org/u/companyhen)
#### Post date: [2016年十二月2日 00:01 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/7 "2016-12-02T00:01:58Z")

</div>

I restarted my server now this is happening:

root@forum:/var/discourse# ./launcher rebuild app  
Ensuring launcher is up to date  
Fetching origin  
Launcher is up-to-date  
Stopping old container

- /usr/bin/docker stop -t 10 app  
app  
cd /pups && git pull && /pups/bin/pups --stdin  
Already up-to-date.  
I, [2016-12-02T00:00:21.369933 #14] INFO – : Loading --stdin  
I, [2016-12-02T00:00:21.381560 #14] INFO – : \> mkdir -p /shared/postgres\_run  
I, [2016-12-02T00:00:21.389944 #14] INFO – :  
I, [2016-12-02T00:00:21.390801 #14] INFO – : \> chown postgres:postgres /shared/postgres\_run  
I, [2016-12-02T00:00:21.395122 #14] INFO – :  
I, [2016-12-02T00:00:21.395880 #14] INFO – : \> chmod 775 /shared/postgres\_run  
I, [2016-12-02T00:00:21.399199 #14] INFO – :  
I, [2016-12-02T00:00:21.399893 #14] INFO – : \> rm -fr /var/run/postgresql  
I, [2016-12-02T00:00:21.403201 #14] INFO – :  
I, [2016-12-02T00:00:21.403831 #14] INFO – : \> ln -s /shared/postgres\_run /var/run/postgresql  
I, [2016-12-02T00:00:21.407292 #14] INFO – :  
I, [2016-12-02T00:00:21.407911 #14] INFO – : \> socat /dev/null UNIX-CONNECT:/shared/postgres\_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1  
I, [2016-12-02T00:00:21.423887 #14] INFO – : postgres already running stop container

## FAILED

Pups::ExecError: socat /dev/null UNIX-CONNECT:/shared/postgres\_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1 failed with return #\<Process::Status: pid 21 exit 1\>  
Location of failure: /pups/lib/pups/exec\_command.rb:108:in `spawn’  
exec failed with the params “socat /dev/null UNIX-CONNECT:/shared/postgres\_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1”  
69f7797520f27421762f39f0c5f23d4b182b0b297b3dc71f77452f191afbc741  
\*\* FAILED TO BOOTSTRAP \*\* please scroll up and look for earlier error messages, there may be more than one

---

<div class="post-metadata">

### Author: ![Steven](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/steven/32/187890_2.png) [@Steven](https://meta.discourse.org/u/Steven)
#### Post date: [2016年十二月2日 00:26 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/8 "2016-12-02T00:26:47Z")

</div>

I’m not a pro, but until someone helps you I would try this :

First a docker upgrade and a reboot :

```
sudo apt-get upgrade docker-engine
shutdown -r now

```

Reconnect after a few seconds. And try a rebuild again :

```
git pull
./launcher rebuild app

```

---

<div class="post-metadata">

### Author: ![companyhen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/companyhen/32/121250_2.png) [@companyhen](https://meta.discourse.org/u/companyhen)
#### Post date: [2016年十二月2日 01:16 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/9 "2016-12-02T01:16:36Z")

</div>

Thanks that fixed the issue.

---

<div class="post-metadata">

### Author: ![Steven](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/steven/32/187890_2.png) [@Steven](https://meta.discourse.org/u/Steven)
#### Post date: [2016年十二月2日 02:17 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/10 "2016-12-02T02:17:29Z")

</div>

Thanks to @awole20 who corrected me on something 😅

Glad it worked

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [2016年十二月2日 07:37 UTC](https://meta.discourse.org/t/cant-rebuild-app/53648/11 "2016-12-02T07:37:48Z")

</div>


