Can't run a bundle exec command


(Dorianamouroux) #1

Hi,

I’m trying to run the following command:

bundle exec script/discourse remap $OLD_PATH $NEW_PATH

But I get the error:

bundler: failed to load command: script/discourse (script/discourse)
PG::ConnectionBad: FATAL:  Peer authentication failed for user "discourse"

I just install my forum from this guide: discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub
I’m running the last version of Discourse.
Everything works well on the forum, I also can run rails c and have a Ruby console connected to the DB.

In the environment I have RAILS_ENV=production.

Thanks for your help


(Jay Pfaffman) #2

Try just discourse.there is a discourse in /usr/local/bin that sets the user correctly.