# Can't run ./launcher rebuild app - Docker storage driver is unsupported

**URL:** https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927
**Category:** Support
**Created:** [February 5, 2017, 12:09am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927 "2017-02-05T00:09:18Z")
**Posts on this page:** 20
**Page:** 3

<div class="post-metadata">

### Author: ![kraml](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kraml/32/68627_2.png) [@kraml](https://meta.discourse.org/u/kraml)
#### Post date: [March 8, 2017, 3:41pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/41 "2017-03-08T15:41:41Z")

</div>

So you are on RHEL 7, which doesn’t have AUFS support. The next recommended storage driver is overlayfs. You need to change the “aufs” parameter in docker.conf to “overlay” or “overlay2”.

And hold on, you probably will run into another problem if you system is installed all by default setting. Check this post for detail.

> [@Bootstrap fails on CentOS 7](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/20):
>
> Most probably it’s because the backing xfs filesystem was not created with ftype=1 option. This is very common if you let the OS installer format the / fs and you just have /var/lib/docker on /. On newer docker verision (1.13?) with docker info you can see support d\_type = false and that indicates your xfs was created with ftype=0 instead of the required ftype=1. This will cause weird issues if you use overlayfs on top of it. See below issues for detail: [https://github.com/docker/docker/issue…](https://github.com/docker/docker/issues/27358)

---

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [March 8, 2017, 7:44pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/42 "2017-03-08T19:44:24Z")

</div>

Thanks changing from aufs to overlay in the docker.conf file it works and now as you said I have the bootstrap fail 🙂

```
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && chown -R discourse /var/www/discourse failed with return #<Process::Status: pid 270 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"web", "cmd"=>["gem update bundler", "chown -R discourse $home"]}
3aaada322e988d6195fb100e12a136411233baec152e6d0cec43eba5af46a563
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

so i´m going to check out those Posts Bootstrap fails on CentOS 7

---

<div class="post-metadata">

### Author: ![Perfectibilist](https://avatars.discourse-cdn.com/v4/letter/p/b487fb/32.png) [@Perfectibilist](https://meta.discourse.org/u/Perfectibilist)
#### Post date: [March 12, 2017, 11:10am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/43 "2017-03-12T11:10:34Z")

</div>

Care to explain why would this happen? I mean, we didn’t face issues before with this until some changes were done

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [March 13, 2017, 1:03pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/44 "2017-03-13T13:03:49Z")

</div>

There are clear instructions there, if you are going for an unsupported install read the source code of `launcher` and edit out the section you don’t like.

---

<div class="post-metadata">

### Author: ![david](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/david/32/157490_2.png) [@david](https://meta.discourse.org/u/david)
#### Post date: [March 13, 2017, 3:03pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/45 "2017-03-13T15:03:59Z")

</div>

I’ve just done a `git pull` on the /var/discourse directory of my host, and am now getting warnings about using devicemapper. I followed the basic install instructions for digital ocean when I set it up last year, and haven’t messed with any docker settings.

What’s the best way to proceed? Should I be trying to change the storage driver, or starting up a new droplet and restoring a backup?

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [March 13, 2017, 3:06pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/46 "2017-03-13T15:06:04Z")

</div>

> [@david](#):
>
> Should I be trying to change the storage driver

Give this a try it should work.

We store **nothing** critical in AUFS or whatever storage driver you have going. All important data is stored on the host in the `/var/discourse` folder.

---

<div class="post-metadata">

### Author: ![kraml](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kraml/32/68627_2.png) [@kraml](https://meta.discourse.org/u/kraml)
#### Post date: [March 23, 2017, 2:45pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/47 "2017-03-23T14:45:44Z")

</div>

You can:

1. Stop your forum and docker daemon.
2. Move/rename the /var/lib/docker folder.
3. Backup /var/discourse.
4. Change docker storage driver.
5. Start up docker daemon. Then you will notice your discourse container is gone. Don’t panic, it’s only the container definition gone, not data.
6. run launcher bootstrap and you will get a new container created and still pointing to your existing data. Your site will just up running without change.

You don’t have to create a new droplet if you have no problem in step #4.

---

<div class="post-metadata">

### Author: ![singmajesty](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singmajesty/32/115180_2.png) [@singmajesty](https://meta.discourse.org/u/singmajesty)
#### Post date: [March 29, 2017, 4:34am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/48 "2017-03-29T04:34:05Z")

</div>

I had this problem as well

Expanding on the points above, this is what worked for me on my Linode instance (running Ubuntu)

1. Edit “/etc/default/docker”
2. Add `DOCKER_CONF="--storage-driver=overlay"` to the file (and save)
3. Run the following commands

```bash
cd /var/discourse
sudo launcher stop app
sudo service docker stop
sudo mv /var/lib/docker ~/docker_tmp
sudo cp -r . ~/discourse_backup
sudo service docker start
sudo launcher rebuild app
sudo launcher start app

```

---

<div class="post-metadata">

### Author: ![anon36895752](https://avatars.discourse-cdn.com/v4/letter/a/9d8465/32.png) [@anon36895752](https://meta.discourse.org/u/anon36895752)
#### Post date: [April 21, 2017, 5:57pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/49 "2017-04-21T17:57:11Z")

</div>

> [@singmajesty](#):
>
> Add DOCKER\_CONF=“–storage-driver=overlay” to the file (and save)

For me this didn’t work, i had to use:

```
DOCKER_OPTS="--storage-driver=overlay"

```

You can confirm if it works for you by running:

```
docker info | grep Storage

```

---

<div class="post-metadata">

### Author: ![Adi\_Adi](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/adi_adi/32/70081_2.png) [@Adi\_Adi](https://meta.discourse.org/u/Adi_Adi)
#### Post date: [April 22, 2017, 9:32am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/50 "2017-04-22T09:32:01Z")

</div>

@sam Hi I am still unable to change device storage. Tried all above mentioned process.  
Aws ubuntu 12.04 precise 3.2.\* kernel  
Can anyone help!!!

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [April 22, 2017, 10:13am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/51 "2017-04-22T10:13:55Z")

</div>

Ubuntu 12.04? Why bother, that’s so old!

---

<div class="post-metadata">

### Author: ![Adi\_Adi](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/adi_adi/32/70081_2.png) [@Adi\_Adi](https://meta.discourse.org/u/Adi_Adi)
#### Post date: [April 22, 2017, 10:27am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/52 "2017-04-22T10:27:43Z")

</div>

Current live production server is 12.04 precise 3.2.\* kernel…so only

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [April 22, 2017, 12:49pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/53 "2017-04-22T12:49:50Z")

</div>

End of life for precise is now: [Ubuntu release cycle | Ubuntu](https://www.ubuntu.com/info/release-end-of-life)

It’s time to upgrade.

---

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [May 3, 2017, 6:27pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/54 "2017-05-03T18:27:39Z")

</div>

Hi @kraml I created a partition with the indicated format ext4, make a copy of /var/lib/docker named /var/lib/docker\_old and leave a copy of /var/lib/docker with all its files, mount my partition With the correct type of FS with the command  
Sudo mount /dev/sda1/ /var/lib/docker, as I have RHEL also make the prompts to create the docker.conf inside /etc/systemd/system/docker.service.d/ specifying ExecStart=/usr/bin/dockerd --storage-driver=overlay but I can not get it to start the Docker service since it gives me the following error:

```
[Cevmf @ server discourse] $ sudo systemctl status docker -l
[Sudo] password for cevmf:
● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/docker.service.d
           └─docker.conf
   Active: failed (Result: exit-code) since Wed 2017-05-03 14:13:32 EDT; 7 minutes ago
     Docs: https://docs.docker.com
  Process: 8961 ExecStart=/usr/bin/dockerd --storage-driver=overlay (code=exited, status=1 / FAILURE)
 Main PID: 8961 (code=exited, status=1 / FAILURE)
   Memory: 1.5M
   CGroup: /system.slice/docker.service

May 03 14:13:31 server dockerd [8961]: time="2017-05-03T14: 13: 31.970782327-04: 00" level=info msg="libcontainerd: new containerd process, pid: 8964"
May 03 14:13:32 server dockerd [8961]: Error starting daemon: error initializing graphdriver: invalid argument

```

Any ideas?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [May 3, 2017, 7:53pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/55 "2017-05-03T19:53:14Z")

</div>

That’s really more of a Docker/sysadmin question. You might try on a docker forum or stackexchange.

---

<div class="post-metadata">

### Author: ![mpalmer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mpalmer/32/45740_2.png) [@mpalmer](https://meta.discourse.org/u/mpalmer)
#### Post date: [May 3, 2017, 11:29pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/56 "2017-05-03T23:29:20Z")

</div>

Remove the spaces around the equals. Spaces separate command line arguments, they’re not just for aesthetics.

---

<div class="post-metadata">

### Author: ![kraml](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kraml/32/68627_2.png) [@kraml](https://meta.discourse.org/u/kraml)
#### Post date: [May 4, 2017, 1:05am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/57 "2017-05-04T01:05:04Z")

</div>

> [@Edgar\_Martinez](#):
>
> mount /dev/sda1/var/lib/docker

Besides of what Matt mentioned about spaces around “=”, here you also missed a space between the partition and the mount dir. Was it only a typo in your post or you actually ran the command like this?

---

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [May 4, 2017, 2:27am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/58 "2017-05-04T02:27:27Z")

</div>

Sorry when I copied the text in the page something made those changes, I corrected it, and yes the mount command was written with a space mount /dev/sda1 /var/lib/docker

---

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [May 4, 2017, 2:43am UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/59 "2017-05-04T02:43:13Z")

</div>

Thanks Matt I don´t know why it pasted like that, but I corrected it.

---

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [May 4, 2017, 9:21pm UTC](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927/60 "2017-05-04T21:21:46Z")

</div>

It finally work and with the Discourse new version so far v1.8.0.beta11 +87 Thanks all for your help @kraml [quote=“kraml, post:47, topic:56927”]  
You can:

Stop your forum and docker daemon.  
Move/rename the /var/lib/docker folder.  
Backup /var/discourse.  
Change docker storage driver.  
Start up docker daemon. Then you will notice your discourse container is gone. Don’t panic, it’s only the container definition gone, not data.  
run launcher bootstrap and you will get a new container created and still pointing to your existing data. Your site will just up running without change.  
[/quote]

[Previous page](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927.md?page=2)

[Next page](https://meta.discourse.org/t/cant-run-launcher-rebuild-app-docker-storage-driver-is-unsupported/56927.md?page=4)
