Can't save the onebox whitelist setting by clicking away


(Marco) #1

I’m trying to add a site to the onebox whitelist, I enter ebay.it in the text field:

and a soon as i click elsewhere (the field looses focus) the entire field is cleared:

I can’t save the setting.


Fix Rake command, whitelist pcpartpicker.com in discourse/Onebox
(Jeff Atwood) #2

Did you try pressing the enter key?


(Marco) #3

LOL, this is fantastic! :smiley:
Not very intuitive though. Really.


(Dean Taylor) #4

I too struggled with the idea pressing enter whilst modifying the censored words…
… enter always feels scary on a web form.

I ended up using the pipe character (I)

For input feels like this one perhaps space could be allowed to work - but that wouldn’t be any good for censored words as they can contain spaces.


(Sam Saffron) #5

I actually consider this a bug, we should show the save button as soon as you start typing there, it totally tripped me for CORs settings the other day.

cc @lightyear


(Mittineague) #6

It does seem odd that changing that input wouldn’t have the same “check” and “x” options appear.


(Arpit Jalan) #7

This issue seems to be fixed now. Not able to repro this anymore.

Can anyone else confim?


(Jeff Atwood) #8