Can't send the reply I wrote (sometimes)


(Deed) #1

Hi, a bug or something prevents me from sending a reply to a public thread but ONLY FROM TIME TO TIME (not always).

My user story : I enter my login/password as a “normal user”. I read a public thread and I want to add my post to the discussion. I click the ‘Reply’ blue button in order to write my message, and text editor appears. I can write the message, add links, quotes, etc. I click on “Reply” button on the lower left.

-> Sometimes, the post is published as expected.
-> Sometimes, nothing happens : post is not published and my answer stays in a ‘draft’ mode. Clicking on the blue ‘Reply button’ does nothing. The button does not work anymore, even for other theads.

So using Discourse is quite disturbing. Sometimes I can post my answer, sometimes not. I can’t identify exactly the reasons that makes the bug happen.
Once the bug happens, I can not post any more reply on the forum.

Configuration :

  • server : The latest Discourse update has been installed (0.9.6.2)
  • me : Mac OS, updated version of Chrome or Safari

Another user has the same problem.

Has anyone already met the same problem ?
What is wrong ?


(Deed) #2

The forum involved : http://forum.madseduction.com/


(Michael Brown) #3

We had been having some CSRF validation problems since adding CSRF checking.

I notice you’re using Phusion Passenger - another other site using Passenger was also having those problems.

I suspect it may be the same problem.

When you’re having problem, can you open the Javascript Console (F12 in Chrome) and note if you see any errors?

If so, you might see something like this in the console:

And you would see errors in the production.log file on the server.

if you’re able to monitor the logfiles from Discourse while attempting to send a reply and post those changes here, that would be very helpful.


(Deed) #4

Thanks for your help, I’ll do that and will post details asap.


(Deed) #5

I could not reproduce the bug in the past days. Maybe the last upgrade solved the problem, as I can post as expected.

Let’s consider the problem as “solved” for the moment.


(Jeff Atwood) #6

There were definitely some CSRF bugs that @sam fixed in the code, particularly related to upgrades.

As always, try to be on latest if you can…


(Jeff Atwood) #7