# Can't start docker after update (openSUSE 13.2)

**URL:** https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995
**Category:** Self-hosting
**Created:** [February 3, 2016, 9:36pm UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995 "2016-02-03T21:36:11Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![elutz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/elutz/32/64158_2.png) [@elutz](https://meta.discourse.org/u/elutz)
#### Post date: [February 3, 2016, 9:36pm UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/1 "2016-02-03T21:36:11Z")

</div>

After updating the docker package I’m not able to start the docker daemon anymore.

```
 lutz@ea-esbz:/var/discourse> sudo systemctl status -l docker
docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled)
   Active: failed (Result: exit-code) since Mi 2016-02-03 21:25:09 UTC; 3s ago
     Docs: http://docs.docker.com
  Process: 28385 ExecStart=/usr/bin/docker daemon -H fd:// $DOCKER_OPTS (code=exited, status=1/FAILURE)
 Main PID: 28385 (code=exited, status=1/FAILURE)

Feb 03 21:25:09 ea-esbz docker[28385]: time="2016-02-03T21:25:09.239522989Z" level=info msg="API listen on /var/run/docker.sock"
Feb 03 21:25:09 ea-esbz docker[28385]: time="2016-02-03T21:25:09.243285203Z" level=warning msg="Usage of loopback devices is strongly discouraged for production use. Please use `--storage-opt dm.thinpooldev` or use `man docker` to refer to dm.thinpooldev section."
Feb 03 21:25:09 ea-esbz docker[28385]: time="2016-02-03T21:25:09.252326106Z" level=fatal msg="Error starting daemon: error initializing graphdriver: Could not query and save base device UUID:Error running deviceCreate (ActivateDevice) dm_task_run failed"

```

The main problem seems to be (see the last line above):  
“Error starting daemon: error initializing graphdriver: Could not query and save base device UUID:Error running deviceCreate (ActivateDevice) dm\_task\_run failed”

Any ideas? Didn’t find an answer in the already psoted topics on meta.discourse  
BTW:

```
docker --version
Docker version 1.9.1, build a34a1d5

```

Lutz

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [February 3, 2016, 10:57pm UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/2 "2016-02-03T22:57:27Z")

</div>

> [@elutz](#):
>
> graphdriver

graphdriver is the worst, try getting aufs going

---

<div class="post-metadata">

### Author: ![elutz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/elutz/32/64158_2.png) [@elutz](https://meta.discourse.org/u/elutz)
#### Post date: [February 3, 2016, 11:19pm UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/3 "2016-02-03T23:19:07Z")

</div>

Hmm, thanks, but as I said I use openSUSE. They stated in

> **[SUSE - Open Source Solutions for Enterprise Servers & Cloud](https://documentation.suse.com)**
>
> Modernize your infrastructure with SUSE Linux Enterprise...

> AUFS: this driver relies on the AUFS union file system. Neither the upstream kernel nor the SUSE one supports this file system. Hence the AUFS driver is not built into the SUSE Docker package.

The same in a special README\_SUSE.md of the SUSE docker package.  
So I’m a bit lost. ☹

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [February 3, 2016, 11:22pm UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/4 "2016-02-03T23:22:59Z")

</div>

> [@elutz](#):
>
> So I’m a bit lost.

I strongly recommend you raise this with docker, in particular with @rhvgoyal here:

[https://github.com/docker/docker/pull/12354#issuecomment-112094794](https://github.com/docker/docker/pull/12354#issuecomment-112094794)

---

<div class="post-metadata">

### Author: ![elutz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/elutz/32/64158_2.png) [@elutz](https://meta.discourse.org/u/elutz)
#### Post date: [February 3, 2016, 11:28pm UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/5 "2016-02-03T23:28:56Z")

</div>

Thanks again, I just poke a bit around on docker’s GitHub. There was a similar issue but with CentOS:  
[https://github.com/docker/docker/issues/16344#issuecomment-156718593](https://github.com/docker/docker/issues/16344#issuecomment-156718593)

But it seems to be a bit dangereous to clear the _/var/lib/docker_.  
Anyway, I will follow your recommendation …

---

<div class="post-metadata">

### Author: ![elutz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/elutz/32/64158_2.png) [@elutz](https://meta.discourse.org/u/elutz)
#### Post date: [February 4, 2016, 12:46am UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/6 "2016-02-04T00:46:10Z")

</div>

Hmppf, this was a bit hard and … strange.  
OK, I did it, I cleaned the `/var/lib/docker/*`. Restarting the docker led to another error, something with `DeleteDevice`.  
Looking at the available space of the drive of the vm yields there was no space anymore. I think this was the culprit at least. Enlarging the disk space (is easy on a vm) and rebooting helped.  
Now I was able to rebuild Discourse and all is OK again.

Thanks for the prompt answer and for Discourse … of course.  
Lutz

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [February 4, 2016, 1:11am UTC](https://meta.discourse.org/t/cant-start-docker-after-update-opensuse-13-2/38995/7 "2016-02-04T01:11:13Z")

</div>


