CAS auth not redirecting proper in development


(Steve Finkelstein) #1

Hi all,

I am working on getting my discourse setup to authenticate with rubycas-server. After firing up the development environment for discourse, I quickly setup rubycas-server within the same vagrant environment as well. After getting seed data into, I went ahead and enabled CAS in Settings as evidenced here in this screenshot:

I also tried they above and also stripped the :3001 (port) portion of the address worrying that might be causing issues. Since rubycas-server in development runs on port 3001, I wasn’t sure where else to specify it.

The problem is now when I go to login and click the CAS option, a pop up comes up, but the URL it takes me to is not proper as evidenced in this screenshot:

The URL it ends up redirecting me to is /login/ which doesn’t make sense. It’s not the domain set in settings - so something else has to give. I’m probably overlooking something, and that’s why I came here seeking advice. CAS is a perfect solution for me to integrate discourse with a web app I’m building by sharing a user database. This would be an ideal solution if I can figure out why the popup is filling in a bogus URL.

Thanks for any insight, all.

/sf


(Jeff Atwood) #2

Did you ever get this worked out? Does latest version help?