Categories do not show up for some users


(Joshua Hogendorn) #1

I have a category that is 777 for all groups, but 000 for ‘everyone’. This category seems to be visible to users completely at random. Help please?


(Sam Saffron) #2

Screen shots please?


(Joshua Hogendorn) #3

As I see it, admin account:

As a new user sees it:

That users account

Not all users experience this, i cant seem to find a pattern other than ‘newness’

Category permissions:


(Sam Saffron) #5

Hmmm perhaps that user was not added to the group automatically, does hitting refresh in the admin screen fix it (on the groups page)


(Joshua Hogendorn) #6

That appears to fix it yes.


(Sam Saffron) #7

might add it to the consistency check … I wonder under what conditions its not picking up.


(Sam Saffron) #8

hmmm our daily consistency check already refreshes all automatic groups, in case stuff play up, pushing it to run twice daily. Not sure what else I can do, need to find where the hole is.


(Joshua Hogendorn) #9

Just checking in to say that I just tested again with a new user. Impersonated the user, no category. login as admin, check groups, 30 trust level 1’s. refresh, 31 trust level ones. Impersonate, they can see the category.

I have my discourse set up to start all users at trust level one, perhaps the bug is involved with that?


(Sam Saffron) #10

Perfect, that is the bug then


(Joshua Hogendorn) #11

Awesome. any idea on time-to-fix? its one we run into regularly.


(Sam Saffron) #12

I am pretty sure I fixed that a couple of weeks ago, can you retest on latest?


(Sam Saffron) #13

This topic was automatically closed after 3 days. New replies are no longer allowed.