Category missing from 'Latest' when logged in


#1

I am sure there is a sensible explanation for this, but I’ve beat my head against the wall long enough. Hoping someone can help.

On the attached screenshot the view on the left is “Latest” for a guest user logging into my site. The right is “Latest” for me when I am logged in.

I am not seeing “The Packer Wire” topics in my Latest view.

I am not sure what other logged in users are seeing, but I want to make sure Latest includes “The Packer Wire” topics for everyone who is logged in.

Is there a setting somewhere I am overlooking? Or something else that would trigger this behavior?


(David Taylor) #2

Have you muted the category in your user preferences?


#3

I don’t believe so. I also just muted and unmuted. No change.


(David Taylor) #4

Hmmm… are there any unusual security settings on “The Packer Wire” category? Is the “Suppress category from latest” setting enabled on the category?


#5

Nothing appears unusual and “Suppress from…” is not enabled.

Screenshots attached for a second set of eyes.


#6


#7

But again guests see what I would expect.


(David Taylor) #8

That all looks fine to me… is it possible that you’ve muted the individual topics? Try going into one of the topics via a direct link and check the notification level.

Or visit /latest?state=muted


#10

The notification level on individual topics all say “normal”

The latest?state=muted query responds There are no latest topics. That’s sad.

There is this oddity though (in the screenshot) which may be related. I don’t see that as a guest. I am not sure what that is telling me.


(David Taylor) #11

Aha - knew I’d seen this before. Try changing the shared draft settings.


#13

whew! THANK YOU @david I am extremely appreciative of your time and your memory.

It hasn’t actually updated yet, but I’m assuming that is something a Sidekiq job will clean up shortly. Pretty sure I never would have figured that out on my own.


(David Taylor) #15

I don’t think it should require a sidekiq job to fix…

Did you set the shared drafts category to “uncategorized”?


#16

Now it is working. I did set it to “uncategorized”, but I had to log out and back in to see the change.

I again logged out and back in and the admin setting for “shared drafts category” had reverted back to “The Packer Wire”

That was despite me watching the network traffic and seeing a 200 come back from the PUT call.

I have had that happen a few times with various settings though. I’m never quite sure what finally makes it stick.

That said, all appears well now! Thank you again.