Change the default Discourse Icon


Is it possible to change the default icons for the system account? Its the Discourse logo out of the box. Thanks

(Zack) #2

If you mean the logos, then yes. Go to admin > settings > required > logo fields. You can use the post in the staff subforum called site resources or something like that to upload your logos, right click to get the image url, then paste them in the logo fields.

edit: I may have completely misinterpreted your post, if so, zeroflux is correct.


Yes, you can change the avatar for the system user account. Go to Admin > Users and find the system account. Click on the account and then “impersonate” the account. Once you’re impersonating the system account, you can modify the profile, including the profile picture (avatar), username, etc.

There may be other ways to accomplish this as well.


@ZeroFlux Thanks but I’m not getting the impersonate button for the system account. I see it for user accounts but not the system account.

(Zack) #5

Are you an admin or a moderator? Admins can see it, moderators can not.


Actually I’m both admin and moderator

(Dean Taylor) #7

Are you perhaps logged in as the system user?


I’ve tried two admin account i have set up, how can I tell which account system is attached to? When I show emails on the user page System says no_email

What I’ve noticed is that I do not get the impersonate button for any user in the admins group. System is in the admins group. I also can’t seem to figure out how to remove someone from a group.


So it seems that if you log in with the account associated with the developer email you used when you installed Discourse, you can impersonate system.

(Jeff Atwood) #10

I didn’t have to impersonate system to change system avatar. I just

  • logged in as admin
  • went to system’s user page
  • clicked “preferences”
  • edited avatar for system



Are your talking about this page /admin/users/system ? If so, where is “preferences”?


(Robbo) #12

No, go to the system users profile, for example here Profile - system - Discourse Meta. Then since you are admin you click preferences and edit it.

(Kane York) #13

@Stackfish will want to go to /users/system/preferences and that’ll do it.


That works thanks everyone for the help