# PostgreSQL 9.5.12 および 10.3 の変更により、バックアップ関連の失敗が発生

**URL:** https://meta.discourse.org/t/changes-introduced-in-postgresql-9-5-12-and-10-3-cause-backup-related-failures/82555
**Category:** Bug
**Created:** [2018 年 3 月 8 日午後 9:50 UTC](https://meta.discourse.org/t/changes-introduced-in-postgresql-9-5-12-and-10-3-cause-backup-related-failures/82555 "2018-03-08T21:50:57Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [2018 年 3 月 8 日午後 11:34 UTC](https://meta.discourse.org/t/changes-introduced-in-postgresql-9-5-12-and-10-3-cause-backup-related-failures/82555/3 "2018-03-08T23:34:55Z")

</div>

> [@pfaffman](#):
>
> As a stopgap, is there some way to push Docker images that have 9.5.11 in them so that we can go back to our dangerous, but happy lives?

We’re looking at this, yes.

In the meanwhile as a workaround in a container you can backrev your `postgresql-client-9.5` packages to below 9.5.12 (or below 10.3) and the backup will work.

> [@pfaffman](#):
>
> It’s as if the database didn’t actually get dropped or. . . something?

More or less: under the hood we restore to the `restore` schema and then atomically switch that to the `public` (production) schema so that the site is “up” during the restore. But these new versions of `pg_dump` generate a script that _explicitly_ refers to the `public` schema… 💥 restore fails.

---

_[View the full topic](https://meta.discourse.org/t/changes-introduced-in-postgresql-9-5-12-and-10-3-cause-backup-related-failures/82555)._
