Changing from https -> http broke most avatars. Reverting doesn't fix them


#1

When I tried changing discourse from https -> http, it broke a bunch of avatars but mysteriously left a few like this. All avatars currently come from SSO with our main app.

What I’ve done in an attempt to fix this:

  • Revert and go back to HTTPS
  • Remove fastly CDN, point directly to digitalocean IP address instead
  • Try overriding broken avatar but forcing override using SSO
  • of course, running ./launcher rebuild app after all changes

None of these worked. Here’s the error I’m getting in logs:

Discourse::InvalidParameters (url) /var/www/discourse/lib/file_helper.rb:10:indownload’`

And I believe this line is responsible:

return proxy_avatar(Discourse.store.cdn_url(optimized.url))

`

Any help would be greatly appreciated.


#2

Update: I’ve tried these to no avail:

rake avatars:refresh
rake avatars:clean
rails c -> OptimizedImage.destroy_all
rake posts:rebake


(Jeff Atwood) #3

Not sure, any ideas here @sam?


#4

Fixed the issue only by disabling S3 + running
rake uploads:clean_up

(Not sure exactly which one, since I ran both around the same time, but possibly both were necessary).


(Sam Saffron) #5

Its a bug on our side, download is not handling the // prefix … fixing it


(Régis Hanol) #6

FTR: @sam fixed it a couple of hours ago :wink:


(Jeff Atwood) #7