Changing profile picture results in 500 server error


(Sander Datema) #1

I have these errors and I have no idea how to solve this. After a launcher rebuild app I could change the picture of two users and then the third went bad. And those other two didn’t work either before that rebuild.

It’s complaining about not being able to open /var/www/discourse/public/assets/select2.png.

2016/02/17 20:34:50 [error] 54#54: *203 connect() to [2400:cb00:2048:1::6819:f017]:443 failed (101: Network is unreachable) while connecting to upstream, client: 172.17.0.1, server: _, request: "GET /letter_avatar_proxy/v2/letter/f/57b2e6/240.png HTTP/1.0", upstream: "https://[2400:cb00:2048:1::6819:f017]:443/v2/letter/f/57b2e6/240.png", host: "domain.ext", referrer: "https://domain.ext/admin/users/5/frida"
2016/02/17 20:34:50 [error] 54#54: *203 connect() to [2400:cb00:2048:1::6819:f117]:443 failed (101: Network is unreachable) while connecting to upstream, client: 172.17.0.1, server: _, request: "GET /letter_avatar_proxy/v2/letter/f/57b2e6/240.png HTTP/1.0", upstream: "https://[2400:cb00:2048:1::6819:f117]:443/v2/letter/f/57b2e6/240.png", host: "domain.ext", referrer: "https://domain.ext/admin/users/5/frida"
2016/02/17 20:37:37 [error] 54#54: *296 open() "/var/www/discourse/public/assets/select2.png" failed (2: No such file or directory), client: 172.17.0.1, server: _, request: "GET /assets/select2.png HTTP/1.0", host: "domain.ext", referrer: "https://domain.ext/users/frida/preferences"

Not sure if this is related, but there are IPv6 errors as well.


(Sander Datema) #2

Anyone any idea? :worried:


(Jeff Atwood) #3

¯\_(ツ)_/¯


(Sam Saffron) #4

Sounds to me like you have no access to the external world from your install… try setting external system avatars enabled to false.


(Sander Datema) #5

In an odd move I tried de-activating and re-activating those users et voilà, that fixed it.