Changing the profile image does nothing (stable)


(Loic Dachary) #1

Bonjour,

Yesterday I created a new forum instance from GitHub - discourse/discourse_docker: A Docker image for Discourse at f36dd31cfbba2a99091e451920b13efee8f99838 and it works fine. Except modifying the profile image for an account. It is always set to

8_1

I did docker logs --tail=200 -f app hoping to find error messages but it does not complain.

Does that ring a bell?


(Loic Dachary) #2

With a new user I tried to change the profile picture by uploading a new image. And it worked during a few seconds. I saw it changed at the top right of the page. And then I posted a reply to a topic. And I saw it there to… but a second later it reverted to the default image above. And the top right profile image also reverted. What is this sorcery ? :slight_smile:


(Jeff Atwood) #3

Did you follow the setup guide exactly at https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md ?


(Loic Dachary) #4

No, not exactly, the commands are run via ansible and use a pre-defined containers/app.yml.

Since it does not appear to be a known issue, I’ll deploy exactly as instructed to find the source of the problem. Which is most likely something I missed…

And I will report back here to close the thread.

Thanks for the quick reply!


(Jay Pfaffman) #5

I think it means that there is a problem with the image getting to uploads or the uploads not being served correctly.


(Loic Dachary) #6

I have deployed exactly as instructed using a fresh virtual machine and:

  • stopped the container with docker rm -f app
  • cp containers/app.yml /tmp/app.yml and changed version: stable
  • cleanup the repository with git clean -qffdx
  • cp /tmp/app.yml containers/app.yml
  • ./launcher rebuild app
  • ran through the wizard when ready, confirm the mail

app.txt (3.7 KB)

After deploying I did the following:

What am I doing wrong?


(Loic Dachary) #7

On the same machine used to run the above reproducer, I removed version: stable from /tmp/app.yml and did the following:

  • ./launcher app destroy
  • git clean -qffdx
  • cp /tmp/app.yml containers
  • ./launcher app rebuild
  • confirmed the email and complete the wizard
  • the profile picture is the expected gravatar associated with loic@dachary.org
  • uploading a new image immediately reflects in the page

I’m starting to think this problem is real and not something from my environment. But at the same time it seems odd that I’m the only one reporting it. I would be immensely grateful if someone could try to reproduce it given the steps above.