Clean install, mail not sent


#1

first hello together!

since today morning I am trying to install discourse.
All works fine, but at registering the mail was not sent.

My last Mailsettings in app.yml:

DISCOURSE_SMTP_ADDRESS: sx.server.de
DISCOURSE_SMTP_PORT: 465
DISCOURSE_SMTP_ENABLE_START_TLS: true
DISCOURSE_SMTP_OPENSSL_VERIFY_MODE: none
DISCOURSE_SMTP_USER_NAME: info@server.de
DISCOURSE_SMTP_PASSWORD: "psdsdbDQ"
DISCOURSE_SMTP_AUTHENTICATION: "login"

in production.log I got:

Sent mail to basti@sdsdsd.com (60055.3ms)
Job exception: Net::ReadTimeout

I checked my settings a hundred times.
In Thunderbird I have:

port: 465
security: ssl/tls
authentication: password, normal

My Mailserver says:

postfix/smtpd[28336]: SSL_accept error

Does someone here have a hint, where I can search the fault, or which log can help me?

Thanks in advance


(Matt Palmer) #2

Oh so many, many things wrong with this…

Port 465 (and the attendant protocol, SMTPS) are dead, buried, and long unsupported. SMTPS never supported STARTTLS, so you definitely shouldn’t have that on. You’re not even getting as far as a connection, though, so something’s broken with your network connection (firewall, upstream port blocking, etc). There’s a whole topic on troubleshooting mail, you should find it and read it.


#3

First thanks to your answer!
Last 20 hours I read many many posts here, but none of them helped me to get mail working.

I think I did something wrong, but cant find the right way to get mail working.
If I try:

openssl s_client -crlf -connect mailserver:465

and after “ehlo testing” I got:

250-PIPELINING
250-SIZE 51200000
250-ETRN
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

All seems fine and I can login…
But if I try it with discourse i get everytime: “Job exception: Net::ReadTimeout” in production.log and “postfix/smtpd[28336]: SSL_accept error” on mailserver

Can somebody help me to find the right settings?

And yes this is a old mailserver… but we can change this not in the next weeks :frowning:

THANKS!!


(Matt Palmer) #4

Still smells like the network. Packet captures will at least let you see why the read timeout is happening.


#5

Hi Matt,
thanks again…
via shell all works fine from host.

now I tested:

./launcher enter app
=> retried openssl ->ehlo testing->AUTH PLAIN 
=> logged in
=>mail sent and received

Perhaps you have further hints, how to setup mail…

thanks in advance!