Clicking on a tag causes loading error


#1

I use several tags in my discourse. Recently i dicided to change a categroies name and url equal to a tag. Since then, whenever clicking on that specific tag i get a loading error.


#2

I tried to reproduce this behavior but it wasnt possible so it must have another source.
Does anyone have had issues with his tags and could solve them? A rebuilld doesnt solve it and I really dont have any clue how to handle this.


(Waldir Pimenta) #3

I’m getting this error in this very site. Try loading Topics tagged emoji. Not sure whether this is a bug with Discourse, this site’s setup, the specific tag, or something else, but for one it definitely doesn’t seem limited to open the url by specifically clicking on the tag, as the title may indicate.


(Jeff Atwood) #4

Can you check this out @eviltrout?


(Kane York) #5

I’m seeing a 404 on Discourse Meta .


(Robin Ward) #6

This was a really odd one. We had a regular expression in our nginx config set to cache any urls with emoji in it for 1 year. That means any urls with emoji in them could be cached incorrectly which is bad. I’ve fixed it to only cache image extensions that way.

https://github.com/discourse/discourse/commit/2866440968769d4336b773b30b01c35e043cb3a3


#7

Im happy to see that this issue got solved. I already updated to latest but unfurtunatly this doesnt solved my problem, as i supposed :disappointed:

My tag is called “Werbung”, perhaps there is a similar regular expression ? :sweat_smile:


(Robin Ward) #8

I highly doubt it. Do you have any way to reproduce the error? It’s only one particular tag?


#9

As mentioned in a previous post i tired reproducing it without success, so my first assumpotion seems to be wrong. And yes its the only tag with this error.


(Jeff Atwood) #10

I think you’re on an old version from that screenshot. I suggest getting updated to latest via /admin/upgrade


#11

I am up-to-date.


(Jeff Atwood) #12

I am curious where that megaphone icon in your screenshot is coming from. I assume it was a remap of the “talk bubble” but that icon no longer exists in current versions of Discourse…


(Kane York) #13

It’s one of the shoutbox/chat plugins IIRC.


(Jeff Atwood) #14

That plugin will break stuff, perhaps that’s your problem @h1onE? Try disabling all plugins we don’t ship.


#15

Nope, its the icon from the Babble Chat Plugin, I will give it a try disabling it. By the way, whats the meaning of “IIRC”?


(James Kiesel) #16

Let me know if you can confirm that Babble’s causing it; I want to know about it if so.


(Régis Hanol) #17

It means “If I Recall Correctly:wink:


(Robin Ward) #18

I was happy to fix the Emoji one but if I can’t reproduce the other one unfortunately I can’t fix it.