Composing a message while on a user's preference page does not work


(cpradio) #1

Steps to Repro

  1. Click on a User’s Avatar
  2. Click on Profile
  3. Click on Preferences
  4. Click on Private Message

You will get the following screenshot:

Expected: (skip Step 3 above)


(TechnoBear) #2

Further information: if you try to complete the message, nothing will show in the preview window, and trying to post it will result in a “post cannot be empty” error message.


(cpradio) #3

Seems to be related to the following JavaScript errors:


(Sam Saffron) #4

We have had this issue for a while its quite hard to fix, the wmd editor needs to stop using ids and start using classes.


(Jeff Atwood) #5

Yeah, the workaround is simple: don’t compose messages while on the preferences page of a user’s profile. That’s because there are duplicate editors visible.


(TechnoBear) #6

In the meantime, then, perhaps the non-functioning “Private Message” button on that page could be replaced with a “Show Public Profile” button (as on the admin page). That would avoid confusion and facilitate returning to the main profile page, either to view changes to one’s own profile, or for a mod to send a message after editing another member’s profile.


(Dave McClure) #7

Just stumbled across this bug another way.

I was composing a message about user preferences. Then I went to my preference page to check something. The part I typed after that did not show up in the preview page and was lost when I clicked ‘Reply’.

  1. click reply on a topic
  2. type part of your reply
  3. visit your preference page
  4. type some more

Definitely an edge case. Just logging it for …well, just because.


(Dean Taylor) #8

This bug looks related both composer and users preferences page mentioned:


(Jeff Atwood) #9

This should work since @eviltrout moved the editor from id (there can be only one, like Highlander) to class.


Missing preview and toolbar when messaging a user via Admin Preferences
(Jeff Atwood) #10