Compressing JS times out 99% of the time

javascript
docker

(Matt Darby) #1

Hi all!

I’m deploying this project successfully to a locally based virtualbox through docker-machine. All is working well. When I go to deploy elsewhere I’m consistently getting this same timeout error. Of note, of the 40~ times I’ve tried it has worked three times. Anyone seen this?

I, [2015-12-03T19:52:55.141175 #244]  INFO -- : Writing /var/www/discourse/public/assets/images/docker-manager-ea64623b074c8ec2b0303bae846e21e6.png
Start compiling CSS: 2015-12-03 19:52:55 UTC
Compiling css for default
target: desktop desktop_ba63bbcacd501c2d5a9a6ca1159d6b88f6f04459.css
target: mobile mobile_ba63bbcacd501c2d5a9a6ca1159d6b88f6f04459.css
target: desktop_rtl desktop_rtl_ba63bbcacd501c2d5a9a6ca1159d6b88f6f04459.css
target: mobile_rtl mobile_rtl_ba63bbcacd501c2d5a9a6ca1159d6b88f6f04459.css
Done compiling CSS: 2015-12-03 19:53:13 UTC
Compressing: admin-fc252c4619166a3585771544f27fe8f4.js
uglifyjs '/var/www/discourse/public/assets/_admin-fc252c4619166a3585771544f27fe8f4.js' -p relative -c -m -o '/var/www/discourse/public/assets/admin-fc252c4619166a3585771544f27fe8f4.js' --source-map-root '/assets' --source-map '/var/www/discourse/public/assets/admin-fc252c4619166a3585771544f27fe8f4.js.map' --source-map-url '/assets/admin-fc252c4619166a3585771544f27fe8f4.js.map'
gzip /var/www/discourse/public/assets/admin-fc252c4619166a3585771544f27fe8f4.js

Compressing: application-3716371c416653f33d778dff8ad0c48c.js
uglifyjs '/var/www/discourse/public/assets/_application-3716371c416653f33d778dff8ad0c48c.js' -p relative -c -m -o '/var/www/discourse/public/assets/application-3716371c416653f33d778dff8ad0c48c.js' --source-map-root '/assets' --source-map '/var/www/discourse/public/assets/application-3716371c416653f33d778dff8ad0c48c.js.map' --source-map-url '/assets/application-3716371c416653f33d778dff8ad0c48c.js.map'
read tcp 104.130.172.27:2376: operation timed out
6b94e65c098ba42456dd5f5e553f4d32d5f7d4ab7dd1cb0e28dac71e1ab6f750
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

Here’s my docker info:

Containers: 0
Images: 7
Server Version: 1.9.1
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 7
 Dirperm1 Supported: false
Execution Driver: native-0.2
Logging Driver: json-file
Kernel Version: 3.13.0-37-generic
Operating System: Ubuntu 14.04.1 LTS
CPUs: 8
Total Memory: 7.793 GiB
Name: discoursetest2
ID: BMLB:LMH6:DY7X:6GRL:RMNE:Q2FG:QOBF:XERV:DYXL:KPRV:RNQ6:6W6B
WARNING: No swap limit support
Labels:
 provider=rackspace

Has anyone seen this?


(Sam Saffron) #2

I have never seen it time out on any of our digital ocean installs, but this is huge red flag for me:

read tcp 104.130.172.27:2376: operation timed out

what is that ip address / port? is there some sort of bash timeout on the box?


(Matt Darby) #3

That IP address is that of my docker host on Rackspace. I’m not on a VPN or anything odd. The 2376 tells me that Docker just kinda gives up or the connection is severed?


(Sam Saffron) #4

Try running tmux or screen and then repeating the rebuild.


(Matt Darby) #5

Do you recommend using something like docker-machine to create the host/launch containers or do you normally have a set docker host where you’d SSH into an run the launcher locally?


(Sam Saffron) #6

We normally ssh in, I have not really seen any timeouts in the past but if connection is sketch I would definitely use tmux cause you can reattach your session


(Matt Darby) #7

Odd. SSHing in and running ./launcher locally works.

Thanks for your help!


(Jeff Atwood) #8