# Configure automatic backups for Discourse

**URL:** https://meta.discourse.org/t/configure-automatic-backups-for-discourse/14855
**Category:** Self-Hosting
**Tags:** backups, how-to
**Created:** [April 18, 2014, 6:21am UTC](https://meta.discourse.org/t/configure-automatic-backups-for-discourse/14855 "2014-04-18T06:21:44Z")
**Posts on this page:** 1
**Showing post:** 101

<div class="post-metadata">

### Author: ![nathank](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/nathank/32/290039_2.png) [@nathank](https://meta.discourse.org/u/nathank)
#### Post date: [December 5, 2020, 7:09am UTC](https://meta.discourse.org/t/configure-automatic-backups-for-discourse/14855/101 "2020-12-05T07:09:18Z")

</div>

> [@Set up file and image uploads to S3](https://meta.discourse.org/t/set-up-file-and-image-uploads-to-s3/7229/164):
>
> I am a bit confused with how to use this guide to configure backups as well.
> 
> I did what I thought made sense but I’ve gotten a little lost along the way and now I am getting “Failed to access backup storage: Access Denied”

I had this problem too, which was resolved by adding a couple of lines to the policy document:

```plaintext
"Resource": [
        "arn:aws:s3:::your-uploads-bucket",
        "arn:aws:s3:::your-uploads-bucket/*",
        "arn:aws:s3:::your-backups-bucket",
        "arn:aws:s3:::your-backups-bucket/*"
      ]

```

Should this be added to the OP (which isn’t a wiki)? Or perhaps in the OP of [Set up file and image uploads to S3](https://meta.discourse.org/t/setting-up-file-and-image-uploads-to-s3/7229)?

---

_[View the full topic](https://meta.discourse.org/t/configure-automatic-backups-for-discourse/14855)._
