Configuring Discourse on localhost - Can't get past mail


(Brooke) #1

Hello,

I’m trying to set up Discourse on LAN only… no connection to the internet… I can get it installed and running but not passed the email part of setup. I know there are similar things out there, but I haven’t found anything as specific as this. In the future, this will still not communicate with the internet.

I’ve configured my localhost, my mailserver, and all that… nostromo.lan
I can send emails between local users IE. root@nostromo.lan > brooke@nostromo.lan and vice versa, however, when I do the initial sign up on discourse I get no email. I tried monitoring the local network traffic… and nothing… it doesn’t appear to be sending anything out.

Anyways, if there is a work around for the email requirement, OR, anyone has an idea for a solution I’d love to have your help.

Thanks,
Brooke


(Brooke) #2

Here is how I have it configured…

 ## TODO: The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: 'discourse.lan'

 ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'brooke@nostromo.lan'

  ## TODO: The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: 'discourse.lan'

## TODO: The mailserver this Discourse instance will use
  DISCOURSE_SMTP_ADDRESS: 127.0.0.1         # (mandatory)
  #DISCOURSE_SMTP_PORT: 25                        # (optional)
  #DISCOURSE_SMTP_USER_NAME: brooke@nostromo.lan      # (optional)
  #DISCOURSE_SMTP_PASSWORD: *******              # (optional)
  #DISCOURSE_SMTP_ENABLE_START_TLS: false           # (optional, default true)

(Flap Jack) #3

A similar thread already exists: Emails with local SMTP – please post there instead.


(Kane York) #4

I think that the dedentation is screwing it up… Put all the comments at least as indented as the DISCOURSE_ lines.

Also 127.0.0.1 is wrong, you need to use the host’s externally-routable IP.