# Connection error after resizing DO Droplet

**URL:** https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596
**Category:** Self-hosting
**Created:** [1월 21, 2018, 6:22오후 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596 "2018-01-21T18:22:01Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![tkrunning](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tkrunning/32/119481_2.png) [@tkrunning](https://meta.discourse.org/u/tkrunning)
#### Post date: [1월 21, 2018, 6:22오후 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/1 "2018-01-21T18:22:01Z")

</div>

Hi guys, I resized my DigitalOcean droplet today, and after that process was completed I haven’t been able to access my Discourse forum (I’m getting ERR\_CONNECTION\_REFUSED).

It looks like something other than Discourse is using port 80… This is what I get when trying to restart the app (I have also rebuilt it, and restarted the DO droplet itself):

```
root@community:/var/discourse# ./launcher restart app
+ /usr/bin/docker stop -t 10 app
app

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (aa51af7b44babc340fc1101b508092e99c65b05cdda7c39ce8337d4f56f0bde7): Error starting userland proxy: listen tcp 0.0.0.0:80: listen: address already in use
Error: failed to start containers: app

```

Any ideas how I can continue debugging or getting this fixed? Discourse was running perfectly fine until I resized the droplet…

---

<div class="post-metadata">

### Author: ![schleifer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/schleifer/32/86416_2.png) [@schleifer](https://meta.discourse.org/u/schleifer)
#### Post date: [1월 22, 2018, 12:15오전 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/2 "2018-01-22T00:15:35Z")

</div>

Run `netstat -plnt` to find what is listening on port 80.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [1월 22, 2018, 1:47오전 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/3 "2018-01-22T01:47:42Z")

</div>

You probably have Nginx or Apache installed on the server. You should remove them and

```plaintext
cd /var/discourse
./discourse-setup

```

to reconfigure Discourse for the amount of RAM you have.

---

<div class="post-metadata">

### Author: ![tkrunning](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tkrunning/32/119481_2.png) [@tkrunning](https://meta.discourse.org/u/tkrunning)
#### Post date: [1월 22, 2018, 7:47오전 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/4 "2018-01-22T07:47:54Z")

</div>

Yup, looks like apache was listening.

```
root@community:~# netstat -plnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1318/sshd       
tcp6 0 0 :::80 :::* LISTEN 1478/apache2    
tcp6 0 0 :::22 :::* LISTEN 1318/sshd       

```

For future reference (or to help other noobs), I ran `sudo apache2ctl stop`, then `./discourse-setup` like @pfaffman suggested to reconfigure for the new amount of RAM. At the end of that process discourse was rebuilt and my site is back up!

I’m not sure if this was necessary, but finally I ran `sudo systemctl disable apache2` to make sure apache does not run when my droplet is restarted in the future. ([Source](https://askubuntu.com/questions/170640/how-to-disable-apache2-server-from-auto-starting-on-boot))

Thanks a lot guys!

---

<div class="post-metadata">

### Author: ![schleifer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/schleifer/32/86416_2.png) [@schleifer](https://meta.discourse.org/u/schleifer)
#### Post date: [1월 23, 2018, 4:17오후 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/5 "2018-01-23T16:17:18Z")

</div>

> [@tkrunning](#):
>
> I’m not sure if this was necessary, but finally I ran `sudo systemctl disable apache2` to make sure apache does not run when my droplet is restarted in the future.

Yes, that was a very good idea.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [1월 23, 2018, 6:46오후 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/6 "2018-01-23T18:46:45Z")

</div>

Right. Perhaps a better idea would be

```
apt purge apache2

```

but that’s assuming that your apache server package is named just that. You can see what all apache stuff is installed like

```
sudo dpkg -l |grep apach

```

You really need to un-install the main server part. The other stuff won’t hurt you and can get removed with

```
apt -y autoremove

```

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [4월 14, 2020, 11:17오후 UTC](https://meta.discourse.org/t/connection-error-after-resizing-do-droplet/78596/7 "2020-04-14T23:17:33Z")

</div>


