Connectivity/Configuration issue with separate data container


(Daniel Lynch) #1

I’m trying to use a separate data container and I’m running into an error message:

PG::ConnectionBad: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket “/var/run/postgresql/.s.PGSQL.5432”?

Which is confusing because it shouldn’t be looking for a connection on a domain socket, it should be trying to connect via the network!

Here is my web_only.yml file:

# IMPORTANT: SET A SECRET PASSWORD in Postgres for the Discourse User
# TODO: change SOME_SECRET in this template

templates:
  - "templates/web.template.yml"
  - "templates/web.ratelimited.template.yml"

expose:
  - "80:80"
  - "2222:22"

# Use 'links' key to link containers together, aka use Docker --link flag.
links:
  - link:
      name: data
      alias: data

# any extra arguments for Docker?
# docker_args:

params:
  ## Which Git revision should this container use? (default: tests-passed)
  #version: tests-passed

env:
  LANG: en_US.UTF-8
  ## TODO: How many concurrent web requests are supported?
  ## With 2GB we recommend 3-4 workers, with 1GB only 2
  ## If you have lots of memory, use one or two workers per logical CPU core
  #UNICORN_WORKERS: 3

  ## TODO: configure connectivity to the databases
  #DISCOURSE_DB_SOCKET: ''
  #DISCOURSE_DB_USERNAME: discourse
  DISCOURSE_DB_PASSWORD: REDACTED
  DISCOURSE_DB_HOST: data
  DISCOURSE_REDIS_HOST: data
  ##
  ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'REDACTED'
  ##
  ## TODO: The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: 'despicable.squadwars.org'
  ##
  ## TODO: The mailserver this Discourse instance will use
  DISCOURSE_SMTP_ADDRESS: smtp.mailgun.com         # (mandatory)
  #DISCOURSE_SMTP_PORT: 587                        # (optional)
  DISCOURSE_SMTP_USER_NAME: discourse@mg.squadwars.org      # (optional)
  DISCOURSE_SMTP_PASSWORD: REDACTED              # (optional)
  ##
  ## The CDN address for this Discourse instance (configured to pull)
  #DISCOURSE_CDN_URL: //discourse-cdn.example.com

volumes:
  - volume:
      host: /var/discourse/shared/web-only
      guest: /shared
  - volume:
      host: /var/discourse/shared/web-only/log/var-log
      guest: /var/log

## The docker manager plugin allows you to one-click upgrade Discouse
## http://discourse.example.com/admin/docker
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - mkdir -p plugins
          - git clone https://github.com/discourse/docker_manager.git
  before_bundle_exec:
    - file:
        path: $home/config/multisite.yml
        contents: |
         squadwars:
           adapter: postgresql
           database: squadwars
           pool: 25
           timeout: 5000
           db_id: 2
           host_names:
             - discourse.squadwars.org

  after_bundle_exec:
    - exec: cd /var/www/discourse && sudo -E -u discourse bundle exec rake multisite:migrate
## Remember, this is YAML syntax - you can only have one block with a name
run:
  - exec: echo "Beginning of custom commands"

  ## If you want to configure password login for root, uncomment and change:
  ## Use only one of the following lines:
  #- exec: /usr/sbin/usermod -p 'PASSWORD_HASH' root
  #- exec: /usr/sbin/usermod -p "$(mkpasswd -m sha-256 'RAW_PASSWORD')" root

  ## If you want to authorized additional users, uncomment and change:
  #- exec: ssh-import-id username
  #- exec: ssh-import-id anotherusername

  - exec: echo "End of custom commands"
  - exec: awk -F\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print "Authorized SSH keys for this container:"; } NF>=2 {print $NF;}'

The data container itself starts up just fine, and I have verified that I can ping it (using the IP 172.17.0.2) from a busybox container.


Unable to upgrade discourse with separate data container
Bizarro Stack Overflow
#2

Try uncommenting

  #DISCOURSE_DB_SOCKET: ''

(Daniel Lynch) #3

Thanks for the reply! I just tried it, same error :confused:


#4

meh, do the username as well

Pretty sure when I set it up recently I had everything in that section uncommented.


(Daniel Lynch) #5

Same thing! :frowning: I found someone who had the same error as me:

https://meta.discourse.org/t/multisite-for-dummies/25485/17?u=dlynch158&source_topic_id=39546

And apparently there’s a solution which is to add PGHOST and PGPASSWORD environmental variables.

https://meta.discourse.org/t/multisite-for-dummies/25485/26?u=dlynch158&source_topic_id=39546

It /seems/ to have worked. Although I did get an error:

discourse bundle exec rake multisite:migrate
URGENT: ERROR:  relation "site_settings" does not exist
LINE 1: SELECT name, data_type, value FROM site_settings
                                           ^
 Failed to initialize site squadwars

But I can reach both of the forums so… maybe it worked despite that error. I’ll update this post with more info. I’m disappointed that the multsite topic is not up-to-date tho… unless I did something wrong. Also I don’t really like having to specify the IP address because I don’t know if that might change in the future.


Multisite configuration with Docker
(Sam Saffron) #6

Try first getting this working without multisite before adding that spanner into the works.


(Daniel Lynch) #7

I thought it’d be simpler to just start it off the way I wanted it. Anyway, both sites appear to be working now, but it did require setting the PGHOST and PGPASSWORD variables, which isn’t mentioned in the multisite wiki. At least I was able to use the ‘data’ name instead of the IP address so I’m happy about that.


(Sander Datema) #8

I’ve been getting that error for ages, but all my multisite forums seem to work fine. So I chose to ignore it eventually.


(Daniel Lynch) #9

Hey @Sander78 is there anyway you could paste your web_only.yml for me? I’ve been unable to upgrade because of the database error (see my post at Unable to upgrade discourse with separate data container )

Would reaaaally appreciate it.


(Sander Datema) #10

I don’t use separate containers. But I use about the same app.yml as this one: