Correction for french invite translation


(Doctor Who) #1

Hello,

I’m actually using on Digital Ocean : Discourse 1.2
I make test and got a problem with french invite template email. There are some mistakes I wish to correct.
So :

  • Where could I improve for Discourse french translation for be integrated in next release ?
  • Before the next automatic update, how could I correct this in my actual Discourse installation ?

Best


(Régis Hanol) #2

We host all of our translations on transifex.

I’m actually not sure, @techapj, you got any ideas?


(Arpit Jalan) #3

There’s a plugin by @lidel which allows manual override of translations, have a look:


(Doctor Who) #4

Ok i’ve register and repair the mistake, it’s done now :slight_smile:

Ok I will try it and do a feedback as soon as possible


(Doctor Who) #5

I’m back.

@techAPJ, I’ve download improved french traduction from transifex
Then clone plugin repository : https://github.com/Doctor-Who/discourse-locale-override

Then add following line to the containters/app.yml

hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - mkdir -p plugins
          - git clone https://github.com/Doctor-Who/discourse-locale-override.git

and rebuild app but … invitation still have wrong version …

In the app.yml, should I edit file

env:
  LANG: en_US.UTF-8

to

env:
  LANG: fr_FR.UTF-8

or doing it from Discourse admin in default_local is enough ?

Thanks for your help


(Arpit Jalan) #6

Setting the default locale to fr from admin settings should be enough.


(Doctor Who) #7

ok @techAPJ so I’ve got no idea why it’s not working … :frowning:


(Arpit Jalan) #8

@lidel can you have a look here?


(Marcin Rataj) #9

Hm… sadly I don’t have any idea beside the fact that french translation at Transifex starts with fr_FR:

https://github.com/Doctor-Who/discourse-locale-override/blob/52be04181fede2c68612f281a3992fb142e9543d/config/locales/server.fr.yml#L1

while in Discourse sources fr is used (yes, this in no typo – probably some kind of script does this conversion automatically):

@doctorwho please try to change first line in your custom translations to fr:

- fr_FR:
+ fr:

Hope this helps.


Unable to upgrade, button disappear on DigitalOcean
(Mittineague) #10

Wouldn’t it be better to change “fr” to “fr_FR” to allow for other French dialects?

French - Belgium	fr_BE
French - Canada		fr_CA
French - France		fr_FR
French - Luxembourg	fr_LU
French - Switzerland	fr_CH

I’m guessing they could all “figure it out” well enough, but just the same, it would be more “professional” IMHO


(Doctor Who) #11

@lidel It works ! This is amazing ! Thank you so much !

Why not :slight_smile: