# Could not resolve host: github.com for SamSaffron/pups.git

**URL:** https://meta.discourse.org/t/could-not-resolve-host-github-com-for-samsaffron-pups-git/32050
**Category:** Support
**Tags:** docker
**Created:** [August 13, 2015, 5:04am UTC](https://meta.discourse.org/t/could-not-resolve-host-github-com-for-samsaffron-pups-git/32050 "2015-08-13T05:04:26Z")
**Posts on this page:** 1
**Showing post:** 12

<div class="post-metadata">

### Author: ![MarcP](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/marcp/32/160184_2.png) [@MarcP](https://meta.discourse.org/u/MarcP)
#### Post date: [November 12, 2020, 12:24am UTC](https://meta.discourse.org/t/could-not-resolve-host-github-com-for-samsaffron-pups-git/32050/12 "2020-11-12T00:24:12Z")

</div>

> [@paulraines68](#):
>
> On CentOS8 this error is due to the RHEL7 docker rpms (there are no RHEL8 ones yet) not understanding the new nftables based firewall. One has to setup masquerading by hand for the docker0 interface

I’d like to confirm this solution works. I am on CentOS 8, with Hetzner.

To be specific I ran these commands in order like listed below. ([source](https://serverfault.com/questions/987686/no-network-connectivity-to-from-docker-ce-container-on-centos-8)) - thanks to @paulraines68

```plaintext
# Masquerading allows for docker ingress and egress (this is the juicy bit)
firewall-cmd --zone=public --add-masquerade --permanent

# Specifically allow incoming traffic on port 80/443 (nothing new here)
firewall-cmd --zone=public --add-port=80/tcp
firewall-cmd --zone=public --add-port=443/tcp

# Reload firewall to apply permanent rules
firewall-cmd --reload

```

---

_[View the full topic](https://meta.discourse.org/t/could-not-resolve-host-github-com-for-samsaffron-pups-git/32050)._
