# Kon de meta-waarde van discourse\_post\_id in de database niet bijwerken

**URL:** https://meta.discourse.org/t/could-not-update-the-meta-value-of-discourse-post-id-in-database/309699
**Category:** WordPress
**Created:** [28 mei 2024 om 12:39 UTC](https://meta.discourse.org/t/could-not-update-the-meta-value-of-discourse-post-id-in-database/309699 "2024-05-28T12:39:45Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![npm0912](https://avatars.discourse-cdn.com/v4/letter/n/85e7bf/32.png) [@npm0912](https://meta.discourse.org/u/npm0912)
#### Post date: [28 mei 2024 om 12:39 UTC](https://meta.discourse.org/t/could-not-update-the-meta-value-of-discourse-post-id-in-database/309699/1 "2024-05-28T12:39:45Z")

</div>

Hello!  
I have lately some issues with [WP Discourse](https://github.com/discourse/wp-discourse), when trying to edit a post which has been already posted to Discourse, I try to add some custom fields to the post but when I hit Update, it won’t do it and I receive the message “Updating failed. Could not update the meta value of discourse\_post\_id in database.”  
This error is gone when I disable [WP discourse](https://github.com/discourse/wp-discourse).

what could be the issue?

thanks!

---

<div class="post-metadata">

### Author: ![angus](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/angus/32/341715_2.png) [@angus](https://meta.discourse.org/u/angus)
#### Post date: [28 mei 2024 om 12:47 UTC](https://meta.discourse.org/t/could-not-update-the-meta-value-of-discourse-post-id-in-database/309699/2 "2024-05-28T12:47:52Z")

</div>

Hello @npm0912

This is a generic Wordpress error indicating an issue with your Wordpress installation, that could be caused by a number of things, ranging from an issue with your database, to your caching solution, to some buggy code you have in your theme or some other plugin. It’s the same reason you’re experiencing this issue

> [@Plugin tries to re-publish to Discourse after every update](https://meta.discourse.org/t/plugin-tries-to-re-publish-to-discourse-after-every-update/306899):
>
> Hello, I noticed an issue on our website with the WP Discourse plugin. Basically after we publish a blog post and being successfully published on the Discourse forum, after let’s say 1 week if we do a slight change to the post and update it, the WP Discourse plugin tries to publish it again to the forum. I receive then an email “Discourse Publishing Failure” saying that the embed url has already been taken. I noticed this also when updating very old posts in Wordpress, they are popped up in …

While we can help you with the plugin, the cause of this is an issue with your Wordpress environment, and probably needs a close professional assessment of the real environment.

The confluence of this issue and your other issue, is suggesting to me the most likely cause is that you’re using a significantly out of date version of MySQL in production. But this is just a guess as I don’t have access to your environment.
