Create new topic / reply – auto jump into the text field


(Markus) #1

Some months ago the behaviour to start new topics seems to be changed. I really need the old behaviour back again.

The courser needs to be automatically placed into the composer text field therefore the user will be able to immediately start writing.

Why was this changed recently? – I think, in terms of usability , it’s very important for someone who would answer to someone else, he/she is expecting after pressing “reply”, to instantly start writing without looking for the mouse and activating the right text field.

Best


(Felix Freiberger) #2

For me, the cursor is automatically placed in the title field:

Are you saying that the cursor should be in the content field or that for you, no text field is selected at all? In the latter case: Can you reproduce this here on Meta or on Try? What browser are you using?


(Joshua Rosenfeld) #3

What device/browser is this occurring on?


(Markus) #4

MBP, MacOS High Sierra, Safari Version 11.0

Update: Found the bug…

I recently used a “hack” to hide dozens of subcategories inside the hamburger menu. After deactivation, it seem to work again. :slight_smile:

But… I’d like to use this snippet …

.category-links .category-link.subcategory {
  display: none;
}

What can I do to jump with the courser back into the text field of the composer again? How did you guys solved this issue at meta? It seems, you’re also showing the main categories instead of all of them.


(Joshua Rosenfeld) #5

I don’t have a Mac to test on, but that CSS should in no way be affecting the cursor…not sure who on the team has a MacBook to confirm, that CSS doesn’t cause issues for me on Windows