Create topics notice remains visible


(Matthieu Wipliez) #1

The “create topics notice” that mentions that as an admin I have to create 5 public topics and 30 public posts is not going away, even though the forum has now exceeded these thresholds. I haven’t changed most options, since the defaults are good for me (I’m running a public forum). I am happily using the latest version, and that is the only minor annoyance I have encountered when using Discourse, good work guys :+1:


(Jeff Atwood) #2

Are you sure you are counting only visible topics and posts? e.g. not things in hidden topics or categories visible only to staff or other security groups?

AFAIK this works, but I have seen some sites go crazy with private content and “forget” that the rest of the world can see virtually nothing.


(Matthieu Wipliez) #3

Yes I am, I double checked and visited the forum using private browsing to be sure. I don’t know if you count all topics/posts (including those that are public but were created by system), but even if you don’t, I still count more than enough. See for yourself: https://forum.synflow.com
I am surprised too, did I break something?


(Jeff Atwood) #4

Well, as an anon user, and as a new user (just signed up) I don’t see the notice. So it’s specific to Staff.

But I agree that the counts seem correct, I see well more than 5 public topics and 30 public posts. Any other thoughts here @neil?

Can you update to latest? I would do that first.


(Matthieu Wipliez) #5

Yes, it’s the notice that is only shown to admins (which is why I said it was a minor annoyance):


This can be disabled with the “show create topics notice” setting in Other. From what I found, this was introduced for sites where most or all content is private. I wonder if other admins of Discourse-powered forums have seen this issue?

The forum is already using version 0.9.9.13, which is the latest version.


(Kane York) #6

It’s possible that this is checked during a scheduled job… See if it’s still there tomorrow.


(Jeff Atwood) #7

By “latest” I mean the latest code, not the most recent version.


(Neil Lalonde) #8

Ah, the problem is in the message which was changed here:

https://github.com/discourse/discourse/commit/a963941ebb814208e7212778bea2f085019ebe01

That message wasn’t using the basic_requires_read_posts site setting. I’ll fix. EDIT: fixed.


(Robin Ward) #9