Custom JS in head makes messages not work

(Lars) #1

I’m on the latest update, and messages has stopped working. Clicking my avatar at the top right, then the messages icon no longer works. I guess this is why clicking a username and clicking the “Message” on the card does nothing as well.

I got reports from my users as well :slight_smile:

Is it just me that needs to rebuild or something?

EDIT: Going to a user profile, then clicking “Message” at the top works, oddly.

User profiles no longer showing up after latest update to to v1.9.0.beta2 +95
(Sam Saffron) #2

This works here, so its most likely a plugin.

Can you try in safe mode ?

(Lars) #3

It seemed to work in safe mode. The only third party thing I use (I think) is the Retort-plugin that allows people to react to posts…

Other than that, I don’t recall installing anything else…

(Sam Saffron) #4

Then that would be it :open_hands: raise it with @gdpelican on Retort - a reaction-style plugin for Discourse

(Lars) #5

I just tried disabling everything:

Still doesn’t work though :confused:

(Sam Saffron) #6

That does not necessarily mean it is disabled, try rebuilding without it.

(Lars) #7

OK, I’ll try that! :slight_smile:

(Lars) #8

I rebuilt the app without the retort-plugin (removed it from app.yml) - The issue persists… Any other ideas?

EDIT: Side note: Rebuild caused the server to become unresponsive for a long time, forcing me to power cycle it - the rebuild after that went quickly and the site is now up again…

(cpradio) #9

Do you have any themes that are utilizing JavaScript (and not purely CSS)?

(Lars) #10

@cpradio, that was it. I have some custom fields on the user card and profile. I removed it, and it seems to work now. What is wrong with it?

EDIT: I know it’s a mess, but it was working :stuck_out_tongue:

(cpradio) #11

When you have it enabled, what is the error message that appears in the Dev Console (press F12 in your browser)?

(Lars) #12

When I click the username to bring up the card, this shows:

The message button doesn’t work when the card shows…

(cpradio) #13

I’m fairly certain this is not related but the error message is definitely similar.

Or maybe it is. I’m not seeing anything at a first glance. If I have time, I’ll take a more thorough look later today.

(Sam Saffron) #14

That is a BIG file.

I would do a binary search to see what part of it causes the breakage.

  • Delete half, is it still broken?
  • Delete another half, is it still broken?
  • Etc…

Find the smallest possible repro of the problem.