Custom styling doesn't apply to admin pages

(Adam Capriola) #1

I added this to my stylesheet:

.d-header {
    background: #333;

But it doesn’t apply on admin pages. (I’ve tried refreshing a lot but no dice.)

(Mittineague) #2

This might not be the same issue you’re having, but it might be.

I was playing with CSS on my localhost yesterday and noticed similar.

Even though I did “Save”, the style didn’t take

However, after I shut down the server and started it up again, then the CSS was in effect.

Maybe having an “Apply” would negate the need for a server restart?

(Ben T) #3

Designs (should be/are) disabled for admin pages, in case you break them. This topic might explain why the styles might not be appearing as well.

(Adam Capriola) #4

Ah, ok. That makes sense. It’s still annoying though when my transparent logo looks dashing against my dark background on the frontend, then is neutered on admin pages.



(Kane York) #5

I think it would be safe to have color customizations show up in the admin screens, no?

Something to look forward to! :smile:

(Neil Lalonde) #6

Yeah that should be safe, unless you somehow chose colors that make everything invisible… Hmmm…

(Dan Porter) #7

I was about to report this, but glad I searched.

I felt it was a bug, but as @neil mentioned it’s intended behaviour.

It’s worth mentioning that you can still break your site by inserting broken CSS in the Content->HTML Head section of the admin panel. This applies even in the Admin section.

(Robin Berjon) #8

Could there perhaps be an “Apply to admin as well (DANGEROUS)” setting? Once you have a style enabled and you can tell that it’s not breaking the admin pages, it would be nice to be able to have some consistency.

(Régis Hanol) #9

Since we don’t support styling the /admin section, I just pushed a fix that will automagically disable custom stylesheets in the /admin section and enable them back when you’re leaving it :rose:

Inconsistent body class for /admin paths? (disabling top navigation)
(Régis Hanol) #10