Data Explorer Download - Gives a "Bad CSRF" in Safari

data-explorer

(Bas van Leeuwen) #1

If I try to download the results of the Data Explorer in Safari on Mac (either as JSON or CSV), I get a file containing ["BAD CSRF"]

It works perfectly fine in Chrome


(Michael Brown) #2

Can you check to see whether you have the correct settings related to forcing HTTPS?

(I know we frequently see “BAD CSRF” when there’s an HTTP/HTTPS mismatch, I’m not sure if that is what is causing this particular problem but it’s a good Step 1)


(Bas van Leeuwen) #3

Force https is on
SSL certificate works
We don’t have HSTS yet

What else should we check? :slight_smile:


(Michael Brown) #4

Have you tried…

Kidding aside, I’ll have to wait for one of my other team members who has Safari to take a look.


(Simon Cossar) #5

I’ve tried downloading Data Explorer JSON and CSV results with Safari on my hosted Discourse forum. It’s working for me.


(Sam Saffron) #6

My guess, are you behind cloudflare?


(Kane York) #7

Are you on subfolder? old incorrectly set Path= cookies can cause problems too.


(Bas van Leeuwen) #8

Thanks all, if it’s not happening to others in Safari, then I’ll contact my host :slight_smile:

No

No