Data export failed


(Ivan Rapekas) #1

Hi, I tried to export data from admin dashboard and got export failed. Tried on two instances, 1.9.0.beta11, both work from folder /discuss (not from root /). How can I fix it?

Steps to reproduce:

  1. Go to admin/reports/topics or admin/reports/likes etc. It doesn’t matter, if there is a data for the period or not.
  2. Click Export
  3. Get a system topic with a result ‘Data export failed’

Log message:

Started GET "/discuss/admin/reports/topics?_=1507277465731" for 127.0.0.1 at 2017-10-06 08:11:29 +0000
Processing by Admin::ReportsController#show as JSON
  Parameters: {"_"=>"1507277465731", "type"=>"topics"}
Completed 200 OK in 18ms (Views: 0.2ms | ActiveRecord: 7.4ms)
Started POST "/discuss/export_csv/export_entity.json" for 127.0.0.1 at 2017-10-06 08:11:31 +0000
Processing by ExportCsvController#export_entity as JSON
  Parameters: {"entity"=>"report", "args"=>{"name"=>"topics", "start_date"=>"2017-09-06", "end_date"=>"2017-10-06", "group_id"=>""}}
Completed 200 OK in 14ms (Views: 0.2ms | ActiveRecord: 3.1ms)
Job exception: undefined method `data' for nil:NilClass

214


(Jeff Atwood) #2

What exact version, check the actual hash in view source and compare to GitHub, because there was a bug here that got fixed in the last day or two cc @techAPJ


(Ivan Rapekas) #3

Jeff, thank you for the quick answer! I found the solution 469c677.

I am on tag 1.9.0.beta11 (502f910 with new 110 commits), not on a branch. Our team decided to stay on tag instead of master branch for safety reasons, are they right? :face_with_raised_eyebrow:

Last we upgraded from beta10 to beta11. Now I am not able to upgrade due to setting in app.yml (version: v1.9.0.beta11) with a message:

*** Please be patient, next steps might take a while *** 
Stopping job queue to reclaim memory, master pid is 72 
$ cd /var/www/discourse && git fetch --tags && git reset --hard HEAD@{upstream} 
From https://github.com/discourse/discourse
 - [tag update] latest-release -> latest-release 
fatal: HEAD does not point to a branch

Would you suggest me to comment #version setting to stay on default branch to get the most stable and up-to-date product?


(Jeff Atwood) #4

Just use the default which is tests-passed