# 数据库文件与服务器不兼容（在 Linode 内部更新）

**URL:** https://meta.discourse.org/t/database-files-are-incompatible-with-server-updating-inside-linode/350727
**Category:** Support
**Created:** [2025年二月5日 21:22 UTC](https://meta.discourse.org/t/database-files-are-incompatible-with-server-updating-inside-linode/350727 "2025-02-05T21:22:39Z")
**Posts on this page:** 1
**Showing post:** 10

<div class="post-metadata">

### Author: ![mwaniki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mwaniki/32/313097_2.png) [@mwaniki](https://meta.discourse.org/u/mwaniki)
#### Post date: [2025年二月6日 08:51 UTC](https://meta.discourse.org/t/database-files-are-incompatible-with-server-updating-inside-linode/350727/10 "2025-02-06T08:51:06Z")

</div>

您能否确认一下您的 Docker 版本？如果您使用的版本低于我们推荐的 `24.0.7` 版本，我建议您更新 Docker 然后重试。

在另一个主题中曾报告过类似的问题，更新 Docker 似乎解决了那里的问题。

> [@Postgres error upgrading from 3.3 to 3.4 caused by locale issues](https://meta.discourse.org/t/postgres-error-upgrading-from-3-3-to-3-4-caused-by-locale-issues/345185):
>
> Hi Happy New Year to all. I am trying to update from 3.3 b10 to 3.4 b3. I did the following: cd /var/discourse/git git remote update git pull --rebase origin main Then I did the standard ./launcher rebuild app. I am running Ubuntu 20.04 with Docker 20.10.7. I understand the Docker version is deprecated but the issues seem to come from the Postgre container. I’m getting the following locale error: Stopping old container + /usr/bin/docker stop -t 600 app app 2.0.20241203-0251: Pulling from d…

---

_[View the full topic](https://meta.discourse.org/t/database-files-are-incompatible-with-server-updating-inside-linode/350727)._
