# Database system was not properly shut down error when rebuilding

**URL:** https://meta.discourse.org/t/database-system-was-not-properly-shut-down-error-when-rebuilding/128979
**Category:** Self-hosting
**Created:** [September 19, 2019, 3:39am UTC](https://meta.discourse.org/t/database-system-was-not-properly-shut-down-error-when-rebuilding/128979 "2019-09-19T03:39:23Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [September 19, 2019, 1:14pm UTC](https://meta.discourse.org/t/database-system-was-not-properly-shut-down-error-when-rebuilding/128979/4 "2019-09-19T13:14:06Z")

</div>

Oh.it seems that you have no working container.

The easy solution if you have a backup is to delete the postgres\_data directory, rebuild, and restore the backup. If you don’t have a backup, you might be able to [convert two a two container unshakable] ([Move from standalone container to separate web and data containers](https://meta.discourse.org/t/how-to-move-from-standalone-container-to-separate-web-and-data-containers/29413)).

I don’t know that those instructions make it clear how to move existing data into the new container.

For $500 I’ll fix or give your money back (and there is a considerable chance that I’ll end up wasting my time and give your money neck). My contact info is in my profile.

---

_[View the full topic](https://meta.discourse.org/t/database-system-was-not-properly-shut-down-error-when-rebuilding/128979)._
