Default other enable quoting


(Pad Pors) #1

it says : "Enable quote reply for highlighted text by default. "

when I deactivate this option in the setting menu, it seems it’s still working:

when i highlight some parts of the text, it still shows me "quote reply option.

what does this option in the setting do? and is this a bug, or am i misunderstood?


(Sam Saffron) #2

Reload the page for this to take effect.


(Régis Hanol) #3

Default settings are only applied to new users.


(Pad Pors) #4

have already reloaded the site. may it be cash? and should i rebuild the site ?

do you mean new logins? or is it just new registered users?

the second one seems strange to me.


(Régis Hanol) #5

Sorry, these settings are only applied for newly registered users. They are the default values used when creating a new user.


(Pad Pors) #6

it’s somehow logical, in the sense that an admin sets everything at the beginning of a forum. but sometimes there are un-predicted behavior. and you need to change a setting in the middle of a live forum.

is it possible to apply a setting to all the previous users as well?


(Felix Freiberger) #7

The old users can change the setting for themselves on their preferences page.

Alternatively, you can manually change the setting for all users using the rails console.


(Pad Pors) #8

thanks , is there any howto for using rails console in this case?


(Felix Freiberger) #9

I don’t know a full howto, but I have some inspiration for you :slight_smile:


(Rafael dos Santos Silva) #10

Search is friend!


(Pad Pors) #11

searched already, but with bad terms! included the rails console in the search term which didn’t direct me to any point.

thanks :smiley: