# Device docker0 does not exist

**URL:** https://meta.discourse.org/t/device-docker0-does-not-exist/57633
**Category:** Self-hosting
**Created:** [February 19, 2017, 3:52pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633 "2017-02-19T15:52:04Z")
**Posts on this page:** 19
**Page:** 1

<div class="post-metadata">

### Author: ![m1raz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/m1raz/32/67910_2.png) [@m1raz](https://meta.discourse.org/u/m1raz)
#### Post date: [February 19, 2017, 3:52pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/1 "2017-02-19T15:52:04Z")

</div>

```
Configuration file at containers/app.yml updated successfully!

Device "docker0" does not exist.
Cannot connect to the docker daemon - verify it is running and you have access

```

After installing SMTP appers this. What I can do?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 19, 2017, 3:55pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/2 "2017-02-19T15:55:14Z")

</div>

Are you using Ubuntu? If not, you might switch. It’s the easiest to make work with docker.

---

<div class="post-metadata">

### Author: ![m1raz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/m1raz/32/67910_2.png) [@m1raz](https://meta.discourse.org/u/m1raz)
#### Post date: [February 19, 2017, 3:56pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/3 "2017-02-19T15:56:06Z")

</div>

A’m using VPS with Ubuntu-16.04-x86\_64

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 19, 2017, 3:57pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/4 "2017-02-19T15:57:15Z")

</div>

How did you install docker?

---

<div class="post-metadata">

### Author: ![m1raz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/m1raz/32/67910_2.png) [@m1raz](https://meta.discourse.org/u/m1raz)
#### Post date: [February 19, 2017, 3:59pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/5 "2017-02-19T15:59:29Z")

</div>

By this instruction [https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md](https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md)

With command

`wget -qO- https://get.docker.com/ | sh`

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 19, 2017, 4:03pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/6 "2017-02-19T16:03:48Z")

</div>

Hmm. That’s strange. I did that a couple hours ago on digital ocean without any trouble. If you’re on digital ocean, I’m stumped. If not, then there’s something about the housing service. You can search here or on their site for docker hints.

Perhaps a reboot would help? (But no idea why.)

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [February 19, 2017, 4:34pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/7 "2017-02-19T16:34:04Z")

</div>

Did you run that command as root? If not is the user that ran it part of the docker group?

---

<div class="post-metadata">

### Author: ![m1raz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/m1raz/32/67910_2.png) [@m1raz](https://meta.discourse.org/u/m1raz)
#### Post date: [February 19, 2017, 4:51pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/8 "2017-02-19T16:51:43Z")

</div>

In console I see [root@185.145.253.103](mailto:root@185.145.253.103). I hpe It is root user

---

<div class="post-metadata">

### Author: ![m1raz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/m1raz/32/67910_2.png) [@m1raz](https://meta.discourse.org/u/m1raz)
#### Post date: [February 19, 2017, 6:14pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/9 "2017-02-19T18:14:38Z")

</div>

> [@pfaffman](#):
>
> Perhaps a reboot would help? (But no idea why.)

Didn’t helped. ☹

can I did some tests to found problem? ☹

---

<div class="post-metadata">

### Author: ![mpalmer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mpalmer/32/45740_2.png) [@mpalmer](https://meta.discourse.org/u/mpalmer)
#### Post date: [February 19, 2017, 6:42pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/10 "2017-02-19T18:42:18Z")

</div>

> [@m1raz](#):
>
> Cannot connect to the docker daemon - verify it is running and you have access

This is what you need to do next. Is docker, in fact, running?

---

<div class="post-metadata">

### Author: ![m1raz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/m1raz/32/67910_2.png) [@m1raz](https://meta.discourse.org/u/m1raz)
#### Post date: [February 19, 2017, 7:15pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/11 "2017-02-19T19:15:33Z")

</div>

Looks like it’s not running. When I run anything from docker --help it returns:

`Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?`

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [February 19, 2017, 9:00pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/12 "2017-02-19T21:00:46Z")

</div>

As you said in another topic this was a droplet that had both Apache and Nginx installed, so can you please revert to a new droplet state and try again the official docs for installation?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 20, 2017, 3:07am UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/13 "2017-02-20T03:07:01Z")

</div>

And make sure it’s a standard Ubuntu image and not one with other stuff included.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [January 8, 2018, 6:06am UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/14 "2018-01-08T06:06:56Z")

</div>

FYI we have seen this behavior on Digital Ocean instances where the kernel is way out of date. Per @mpalmer

> Aha, `/var/log/upstart/docker.log` sez, “Your Linux kernel version 3.8.0-29-generic is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer.”

We found that after updating the kernel (this requires using the Digitial Ocean web UI, under Kernel tab) you have to also issue this command

`apt-get -y install linux-image-extra-$(uname -r)`

it is possible that

`apt-get update`  
`apt-get dist-upgrade`

would also work, if issued after the kernel update and reboot.

---

<div class="post-metadata">

### Author: ![slackmoehrle](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/slackmoehrle/32/82215_2.png) [@slackmoehrle](https://meta.discourse.org/u/slackmoehrle)
#### Post date: [January 25, 2018, 5:20pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/15 "2018-01-25T17:20:29Z")

</div>

@codinghorror I tried this for the same issue and no luck. `apt-get dist-upgrade` fails.

```sh
(public)coco@discourse-testing:/var/discourse$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  linux-image-3.13.0-24-generic linux-image-extra-3.13.0-24-generic
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
  postgresql postgresql-contrib
The following packages will be upgraded:
  linux-firmware update-notifier-common
2 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 45.6 MB of archives.
After this operation, 10.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://sfo1.mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 update-notifier-common all 3.168.7 [164 kB]
Get:2 http://sfo1.mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 linux-firmware all 1.157.15 [45.5 MB]
Fetched 45.6 MB in 1s (38.4 MB/s)
(Reading database ... 90884 files and directories currently installed.)
Preparing to unpack .../update-notifier-common_3.168.7_all.deb ...
Unpacking update-notifier-common (3.168.7) over (3.168.5) ...
Preparing to unpack .../linux-firmware_1.157.15_all.deb ...
Unpacking linux-firmware (1.157.15) over (1.157.14) ...
Setting up update-notifier-common (3.168.7) ...
Setting up linux-firmware (1.157.15) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-112-generic
WARNING: missing /lib/modules/4.4.0-112-generic
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/4.4.0-112-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_JKrvXZ/lib/modules/4.4.0-112-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_JKrvXZ/lib/modules/4.4.0-112-generic/modules.builtin: No such file or directory
update-initramfs: Generating /boot/initrd.img-4.4.0-28-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
WARNING: missing /lib/modules/3.13.0-24-generic
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/3.13.0-24-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_pkNDpy/lib/modules/3.13.0-24-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_pkNDpy/lib/modules/3.13.0-24-generic/modules.builtin: No such file or directory

```

```sh
$ service docker start
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'docker.socket'.
Authenticating as: root
Password:
==== AUTHENTICATION COMPLETE ===
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'docker.service'.
Authenticating as: root
Password:
==== AUTHENTICATION COMPLETE ===
Job for docker.service failed because the control process exited with error code. See "systemctl status docker.service" and "journalctl -xe" for details.

```

```sh
$ systemctl status docker.service
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Thu 2018-01-25 12:23:57 EST; 38s ago
     Docs: https://docs.docker.com
  Process: 2457 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
 Main PID: 2457 (code=exited, status=1/FAILURE)

```

```sh
$ sudo journalctl -xe
Jan 25 12:23:57 discourse-testing systemd[1]: Stopping Docker Socket for the API.
-- Subject: Unit docker.socket has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit docker.socket has begun shutting down.
Jan 25 12:23:57 discourse-testing systemd[1]: Starting Docker Socket for the API.
-- Subject: Unit docker.socket has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit docker.socket has begun starting up.
Jan 25 12:23:57 discourse-testing systemd[1]: Listening on Docker Socket for the API.
-- Subject: Unit docker.socket has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit docker.socket has finished starting up.
--
-- The start-up result is done.
Jan 25 12:23:57 discourse-testing systemd[1]: docker.service: Start request repeated too quickly.
Jan 25 12:23:57 discourse-testing systemd[1]: Failed to start Docker Application Container Engine.
-- Subject: Unit docker.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit docker.service has failed.
--
-- The result is failed.
Jan 25 12:23:57 discourse-testing systemd[1]: docker.socket: Unit entered failed state.
Jan 25 12:25:01 discourse-testing CRON[2506]: pam_unix(cron:session): session opened for user root by (uid=0)
Jan 25 12:25:01 discourse-testing CRON[2507]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Jan 25 12:25:01 discourse-testing CRON[2506]: pam_unix(cron:session): session closed for user root
Jan 25 12:25:33 discourse-testing sudo[2533]: coco : TTY=pts/0 ; PWD=/var/discourse ; USER=root ; COMMAND=/bin/journalctl -x
Jan 25 12:25:33 discourse-testing sudo[2533]: pam_unix(sudo:session): session opened for user root by coco(uid=0)

```

```sh
$ sudo /usr/bin/dockerd -H fd:
WARN[2018-01-25T12:28:44.128769214-05:00] [!] DON'T BIND ON ANY IP ADDRESS WITHOUT setting --tlsverify IF YOU DON'T KNOW WHAT YOU'RE DOING [!]
listen tcp: lookup fd on 67.207.67.2:53: no such host

```

I just upgraded from Ubunto 14.04 to 16.04 on a Digital Ocean instance.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [January 25, 2018, 7:09pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/16 "2018-01-25T19:09:05Z")

</div>

> [@slackmoehrle](#):
>
> I tried this for the same issue and no luck. apt-get dist-upgrade fails.

I’d recommend building a new dropet (you want to resize to one of the new ones anyway), starting with 16.04 and backup-restoring your data to the new site.

---

<div class="post-metadata">

### Author: ![slackmoehrle](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/slackmoehrle/32/82215_2.png) [@slackmoehrle](https://meta.discourse.org/u/slackmoehrle)
#### Post date: [January 25, 2018, 7:37pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/17 "2018-01-25T19:37:14Z")

</div>

> [@pfaffman](#):
>
> I’d recommend building a new dropet (you want to resize to one of the new ones anyway), starting with 16.04 and backup-restoring your data to the new site.

I’m trying to avoid doing so. We have a lot of data in Discourse and the downtime and change of IP are also factors. If I have to go this route then perhaps I can stay with 14.04.5.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [January 25, 2018, 8:36pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/18 "2018-01-25T20:36:54Z")

</div>

> [@slackmoehrle](#):
>
> We have a lot of data in Discourse

All the more reason to move to a bigger droplet for the same price you’re paying now.

> [@slackmoehrle](#):
>
> downtime and change of IP are also factors.

- Get a digital ocean floating IP pointing to your current site
- update DNS to point to floating IP
- create new droplet and install Discourse
- wait for DNS to propagate
- back up old site, put in read-only mode
- restore to new site
- re-point floating IP to new site
- change DNS to new IP (or not)

You’d have only a few minutes of read-only time and no downtime.

---

<div class="post-metadata">

### Author: ![slackmoehrle](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/slackmoehrle/32/82215_2.png) [@slackmoehrle](https://meta.discourse.org/u/slackmoehrle)
#### Post date: [January 25, 2018, 10:25pm UTC](https://meta.discourse.org/t/device-docker0-does-not-exist/57633/19 "2018-01-25T22:25:46Z")

</div>

You make a compelling case. Good idea. Thanks.
