Did one-click install on Digital Ocean. Set up SMTP using SparkPost. Not receiving Discourse activation email

(Donald) #1


I created a droplet on Digital Ocean with the Discourse installer. I created an account on SparkPost, created an API key and verified a sending domain forum.mydomain.org

I logged into the droplet using Putty and inputted the following details:

Host: smtp.sparkpostmail.com
Port: 587
Username: SMTP_Injection
Discourse API Key: ******************************************

I logged into the new Discourse install via the IP address, inputted my admin email admin@mydomain.org and username admin. It said that an activation email was sent but I haven’t received anything. I’ve tried multiple times and checked the spam folder.

The only thing I can think of is that I don’t currently have forum.mydomain.org pointed to the Discourse instance in my DNS settings (I’m using AWS Route 53) as I haven’t received a welcome email from Discourse with hosted-by-discourse.com as per the instructions here: Configure your domain name for hosted Discourse

Can somebody please help?

(Joshua Rosenfeld) #2

You’re going to want to go through the email troubleshooting #howto.

If your issue is not resolved after going through the topic, please post the results of each section in the second post here so we can assist further.

(Donald) #3

“Double check the settings in your containers/app.yml file.”

Sorry, but how do I do this? I don’t know how to find this file.

(Felix Freiberger) #4

It should be in /var/discourse/containers/app.yml.

If it’s not there: Can you post a link to the instructions you used for installing Discourse?

(Donald) #5

As in, I don’t know how to access any files at all. After I log into my Digital Ocean droplet using Putty, I am shown this, with seemingly no other option to access files etc.

I followed this: How to use the Discourse One-Click Application on DigitalOcean | DigitalOcean

(Felix Freiberger) #6

These instructions have been updated recently, but the image used is still terribly out of date :cry:

Please create a new droplet using these instructions:

(Christoph) #7

That screen shot says that you have not yet configured discourse. So discourse doesn’t know anything about you or your email, how should it send you a welcome message?

Im not sure what is keeping you from following the instructions that you see when you login so I suggest you try doing that.

Once you completed the setup, you will have to update your discourse so you might as well follow @fefrei’s suggestion and setup a droplet with the latest version right away. But either way should work.

(Donald) #8

Thank you, but I have configured Discourse, multiple times. And then I visit the IP address where my Discourse is hosted, register my admin email, username and password and then it says that an activation email has been sent. I have tried this multiple times and have not received the activation email.

Every time I log into the droplet via Putty, I see those same instructions to configure Discourse, and each time I go through and put in the username, API key etc. and it says that Discourse is now configured.

Anyway, I am going to try deleting the droplet on Digital Ocean and creating a new one, as per Felix’s recommendation.


(Joe Buhlig) #9

Something’s off then. I’ve used those one-click installs a handful of times with no issues. After going through the prompts you should be done. If they come up again, I’d kill it and try again.

It might be a good idea to inform Digital Ocean of the issue as well.


I had the same issue with SparkPost. I contacted SparkPost about the issue and they advised me to use an email address that is not role based. I was able to resolve it by changing my email address to something like firstname@domain.tld. In case you still weren’t able to receive Discourse activation email, here is a link to my solution post below.


The Digital Ocean One-Click Install definitely doesn’t configure everything the same as the Discourse installation instructions.