Digital Ocean one click Intel makes me configure Discourse every time?


#1

Every time I try to connect with my root on PuTTY on my domain or IP address for my Discourse, it keeps doing the first installation (Please press press enter when you are ready to configure Discourse) then asks me the email and stuff, why’s that ?

And also, http works but https doesn’t open for my website, any idea on the reason why ? My initial domain has a SSL bought with namecheap…

Thanks guys !


(cpradio) #2

Did you use DigitalOcean’s one-click install? If so, just press CTRL+C to get out of the installation step


#3

oh god thank you yeah alright it’s fixed now…

Only my https issue remains


(cpradio) #4

You shouldn’t need to purchase SSL (it is free through LetsEncrypt – built into Discourse installation), but since you have a cert already, you should read


#5

Well I had it for free and I didn’t get the chance to install LetsEncrypt on my installation so… alright I’ll try to do the guide, I’ll bump if there’s anything, thanks dude

EDIT : I just don’t know how to remove the HTTPS also


(Bhanu Sharma) #6

You don’t have to install letsencrypt. It’s installed by default when you install discourse.

To activate it, you may try the following steps:

In ssh terminal (putty)

cd /var/discourse
./discourse-setup

When it prompts you to enter details, do make sure that You enter an email ID in the “letsencrypt account email” option.


(Serhat Kapusuz) #7

Finally solution. God bless you…