# 禁用 letsencrypt 失败，运行 discourse-setup 时出现了一些异常警报

**URL:** https://meta.discourse.org/t/disabe-letsencrypt-failed-and-run-discourse-setup-had-some-not-normal-alert/204452
**Category:** Self-hosting
**Created:** [2021 年9 月 25 日 17:43 UTC](https://meta.discourse.org/t/disabe-letsencrypt-failed-and-run-discourse-setup-had-some-not-normal-alert/204452 "2021-09-25T17:43:48Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### 作者： ![luxame19](https://avatars.discourse-cdn.com/v4/letter/l/5f9b8f/32.png) [@luxame19](https://meta.discourse.org/u/luxame19)
#### 发布日期： [2021 年9 月 30 日 06:06 UTC](https://meta.discourse.org/t/disabe-letsencrypt-failed-and-run-discourse-setup-had-some-not-normal-alert/204452/6 "2021-09-30T06:06:02Z")

</div>

@JimPas 感谢您的回复。  
我提供的信息是路径不匹配，因为一个路径是 Docker 卷路径，另一个是真实服务器的文件路径。

[仅高级设置：为您的 Discourse Docker 设置启用 SSL/HTTPS](https://meta.discourse.org/t/advanced-setup-only-allowing-ssl-https-for-your-discourse-docker-setup/13847)

```plaintext
volumes:
  - volume:
      host: /var/discourse/shared/standalone
      guest: /shared

```

看起来不匹配，但实际上是相同的。  
第一个问题我已经解决了。  
对我来说，根本原因是我没有注意到证书格式。  
配置中设置的是 `crt` 格式，但我一直使用的是 `cer` 格式的文件，因此 Nginx 无法成功读取证书文件。

---

_[View the full topic](https://meta.discourse.org/t/disabe-letsencrypt-failed-and-run-discourse-setup-had-some-not-normal-alert/204452)._
