Disable Force SSL Warning


(David Hagar) #1

I’m using Discourse behind HAProxy, so that I can share the site with other web servers working on the same system without worrying about port numbers. The configuration works and HAProxy handles moving all requests from non-SSL over to SSL.

However, if I turn “Force SSL” on in Discourse, the whole thing breaks. Since the last update, I’m getting a warning in my admin panel:

Your website is using SSL. But force_https is not yet enabled in your site settings.

How do I turn this warning off, without having to reconfigure my server to let Discourse handle the SSL, which I’d rather not do (don’t fix what is not broken).


(Jay Pfaffman) #2

It’s a warning. You know it doesn’t apply to you. The easiest solution is to ignore it.


(Jeff Atwood) #3

Things will be broken with this off. The problem is usually incorrect or missing https related proxy headers.


(Vinoth Kannan) #4

I guess you have to send X-Forwarded-Proto to Discourse . The below answer may help you.


(David Hagar) #5

Well, never mind on the setting breaking things. I don’t know why, because I swear I tried to set this after I got the proxy header set properly (required for the preview script to work properly), and it borked the whole thing. This time, however, I set the setting to force HTTPS and it works just fine.

No clue why, truly, no clue why. End of the day, it doesn’t matter. Thanks for the help (as always).