Disable IP Address Spam Blocking


(Kirupa Chinnathambi) #1

Hi everyone! Whenever I and a few of my admins try to login to discourse, we get the:

You can’t log in as kirupa from that IP address.

I checked the IP logs, and I don’t see any flagged IP addresses that match my IP address.

What may be going on? Can I just disable that check?

Thanks,
Kirupa


(Matt Palmer) #2

Look at your screened address list. It should be in there.


(Jay Pfaffman) #3

Do you have a reverse proxy configured? My guess is that the wrong ip is getting to discourse. You can look in the rails logs first to see what up is getting logged. Or look in admin/users to see what IP is logged for you.


(Kane York) #4

Also check for “Allow admin login” IPs - if any of those are set, all admin logins must happen from those IP addresses.


(Kirupa Chinnathambi) #5

Thanks for the responses Matt, Jay, Kane.

Matt - I checked the screened address list, and no IP that even closely matches that appears:

The full IP is much longer, but even the first part of the IP results in nothing being found.

Jay - I don’t have a reverse proxy configured. When I check in admin/users, my IP is being logged correctly.

Kane - I have that disabled, so I am hoping that isn’t causing this problem.


(Jay Pfaffman) #6

Is the ip 192.168.1.x? That’s a non routable address. Are you on a private network?

Did you do a standard install? You’re not using something like cloudflare?


(Mittineague) #7

I have found the IP search will work two ways.

  • the full IP number
  • the partial IP in “mask” format.

for example:
192.0.0.0/8
192.168.0.0/16
192.168.1.0/24


(Kirupa Chinnathambi) #8

Jay - it is a standard install, but I am using cloudflare. Is there anything that I should do differently?


(Jay Pfaffman) #9

Search here for cloudflare.