Disable read-only when testing email settings

There was a problem sending the test email. Please double-check your mail settings, verify that your host is not blocking mail connections, and try again.

I tried many, many permutations of DNS records and app.yml settings, rebuillding the app many times before realising that my settings were not the issue and I just needed to turn off the “read-only” mode in the Backup menu of the Discourse Admin pages.

Perhaps there should be a check for this and a different message “emails will not be sent whilst the site is in read-only mode” ?

Hope this helps someone.

4 Likes

I hear you but I’d like to see this come up more than once before dedicating engineering time to it.

3 Likes