Discobot tutorial certificate blank


(Carl Moebis) #1

After completing the interactive discobot training, the certificate.svg is blank or image not found.


(Jeff Atwood) #2

Unless you can repro here or on try.discourse.org this is a problem with your site’s configuration.


(Carl Moebis) #3

This is on a base Ubuntu 18.04 install, pulled directly from https://github.com/discourse/discourse_docker.git …nothing extra done, about as vanilla as you can get. Is there a SVG library or something missing. I remember in PHP you needed the ImageMagick library installed to handle resizing of images, something similar in the ruby world?

Could Docker be the issue? I’m using the Ubuntu repo Docker 17.x not the docker-ce one (18.x)

EDIT: I just tried removing 17.x and installed docker-ce …still doesn’t work, tried with a new user to go through the tutorial, blank/empty certificate at the end. I also tried this here on your forums, and the first time it broke (nothing showed) then I went back to the discussion later and after a short pause (3-4 secs) it displayed. So this might be a bigger issue.


(Jeff Atwood) #4

It’s a SVG so there is some render time. Is the server you’re building on very slow, or the client?


(Carl Moebis) #5

No, the server is a 2 core, 4GB ram DigitalOcean server. It’s not doing anything, since it’s just a dev setup (1 user). The client machine is a really fast iMac. I refreshed the page several times and let it sit for a couple of minutes, eventually I just get that blue “?” in the middle (times out?). Could Ubuntu 18.04 be the issue?


(Jeff Atwood) #6

What do you see in the browser F12 and network consoles when this happens?


(Carl Moebis) #7


(Rafael dos Santos Silva) #8

Is there any related errors in https://forums.intelligentfanatics.com/logs ?


(Carl Moebis) #9

nope. Completely empty.


(Rafael dos Santos Silva) #10

And if you try to browse https://forums.intelligentfanatics.com/discobot/certificate.svg?date=May+08+2018&user_id=99 in a new tab?


(Carl Moebis) #11

502 Bad Gateway

nginx

EDIT: I fixed it. I did several things. Opened up all the firewall (for http and https), not sure why that would do anything. I ran ./launcher cleanup and then ./launcher rebuild app …now I see the certificates


(Jeff Atwood) #12