Discourse and Wordpress help

(Timothy Vail) #1

Hello, I am trying to install wordpress and discourse on the same Amazon EC2 AWS server. I have discourse all set up already, but no wordpress yet. I tried to follow this guide


up to step 8

Now I am getting the APache2 Ubuntu page when I load my site, but nothing under /phpmyadmin

Where do I go from here?

I have discourse.conf in my nginx/sites-enabled/ and have this in it

upstream forum {
server fail_timeout=0;

upstream php {
    server unix:/tmp/php-cgi.socket;

server {
    server_name mydomain.net *.mydomain.net 46.101.xxx.xxx;
    root /var/www/html;
    ## This should be in your http block and if it is, it's not needed here. <-- it's not there, so I'm leaving it here
    index index.php index.html index.htm;

    location / {
            #try_files $uri $uri/ /index.php?$args;
             try_files $uri $uri/ /index.php?q=$uri&$args; 

    error_page 404 /404.html;

    error_page 500 502 503 504 /50x.html;
    location = /50x.html {
            root /usr/share/nginx/html;

    location ~ \.php$ {
            #NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini <-- I did that
            include fastcgi.conf; # <-- this is crucial
            fastcgi_intercept_errors on;
            try_files $uri =404;
            fastcgi_split_path_info ^(.+\.php)(/.+)$;
            fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
            #fastcgi_pass php;
            fastcgi_index index.php;
            include fastcgi_params;

    # This is for saving resources by caching static content longer
    location ~* \.(js|css|png|jpg|jpeg|gif|ico)$ {
            expires max;
            log_not_found off;

    location = /favicon.ico {
            log_not_found off;
            access_log off;
   location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;

(Jay Pfaffman) #2

You’re not describing a Discourse problem. If you need help getting PHPmyadmin working, a good place to go is https://stackoverflow.com/

(Timothy Vail) #3

Sure, I changed some settings and then it went to the apache main page.

I followed the directions to a T on getting discourse set up a nginx proxy, but it didn’t work. What am I missing, is that guide old?