Discourse backup and restore


(Cee Kay) #1

I had a discourse installation running in one digital ocean droplet!, I had to switch it to another DO droplet due to some reason. (Not technically, discourse was very fine in the first droplet too|). I downloaded the backup and tried to upload it to the new discourse installation.

The system shows a notification box with the success message. But, I cannot see it in backup list. What might be the problem?

after this dialog box, i refreshed the backup page to find the upload backup file reflected in the backups list. But, I couldn’t find it.

But instead, i can see as seen in below image. It is showing as no backup file is uploaded.


(Daniela) #2

Stupid question: do you have enabled the allow restore box in your admin panel?


(Cee Kay) #3

Yes! it was a stupid question. Thank you :slight_smile:


(Régis Hanol) #4

FYI: when you upload a backup, the file is split in small chunks to allow for faster upload and “resumability”.
Once all the chunks have been uploaded, there’s a background job that will merge them into one file which will (only then) show up in the backups list.
Depending on how large your backup is, how fast your droplet is and how busy it is, there might be a delay between the success dialog and the backup showing up in the list.
Also, you need to make sure that sidekiq is running (and not paused), otherwise the merge job won’t run and the backup won’t ever show.


(Cee Kay) #5

I enabled the option, upload the file sirectly into /var/discourse/…/default and restored from it.


(Robin Ward) #6

I have found this UX confusing in the past. I think we should show a message that we’re processing a backup in the background and it’ll be available soon.


(Cee Kay) #7

Yes; I second that.

My forum had a poll and I was afraid to loss it. We should be adding a progress bar/a notification or at lease a message showing that the we are processing the backup in background. I tried to upload the files many times and each time it showed me that upload was successful. It should have given me a info that the backup file was already uploaded or as such. File getting uploaded and not shown in the page was confusing me. That was the reason, I uploaded the file directly to the default folder.


(Jeff Atwood) #8

I agree we should offer more hints here, can you add that to your list @zogstrip?


(Jeff Atwood) #9

I believe @zogstrip added more hints about the backup processing recently :+1: